Page blanche avec la mention "Error" sur Joomla 3.9.24

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Page blanche avec la mention "Error" sur Joomla 3.9.24

    Avé la communauté,

    J'ai tenté plusieurs fois de me connecter avec des mauvais mots de passe côté administrator mais depuis, le site affiche une belle page blanche avec la mention "Error"

    Comment puis-je débloquer cette page blanche et accéder à l'administration, j'ai un autre username/password.


    PS : J'ai accès au site via FTP ... y'a t'il un fichier à modifier chez OVH ?


    En vous remerciant.
    Dernière édition par jeanmarie1778 à 28/04/2021, 08h32
    J'ai bien goûté des substances amères
    et nulle ne l'est plus que l'eau de mer,
    c'est pour cela que je préfère la bière

  • #2
    Bonjour,

    Un tel message, si peu explicite, est souvent lié à une erreur d'accès à la base de données. N'aurais-tu pas changé son mot de passe lorsque tu ne retrouvais pas celui de ton compte sur le site ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      au pire tu peux re-copier les fichiers du dossier /administrator au cas ou.
      cela dédouanera à minima les fichiers.
      sinon en BDD tu mets un login/mot de passe à la main en clair, juste pour accéder à l'admin et tu le changes ensuite.
      Expert en conception et réalisation de sites Internet 100% Joomla
      www.toonetcreation.com

      Commentaire


      • #4
        Envoyé par RobertG Voir le message
        Bonjour,

        Un tel message, si peu explicite, est souvent lié à une erreur d'accès à la base de données. N'aurais-tu pas changé son mot de passe lorsque tu ne retrouvais pas celui de ton compte sur le site ?
        Bonsoir RobertG ... toujours là quand il le faut et depuis de nombreuses années, ça fait plaisir ...

        Disons que j'ai traîné dans le PHPMyAdmin d'OVH où je n'y comprend rien, en espérant que je n'ai rien modifié dedans par inadvertance.
        J'ai repris une sauvegarde d'OVH site/BDD (datant de 15 jours) et toujours pareil.
        J'ai aussi modifié le mot de passe de BDD.

        Comment pourrais-je ravoir le contrôle du site ?

        En te remerciant.



        J'ai bien goûté des substances amères
        et nulle ne l'est plus que l'eau de mer,
        c'est pour cela que je préfère la bière

        Commentaire


        • #5
          Bonjour,

          Tu ne dis pas si le site est accessible ou si c'est seulement l'administration qui est indisponible.
          Si c'est les deux, la première chose serait de restaurer une version de la base antérieure à tes modifications dans phpMyAdmin, de modifier le mot de passe de la base dans le Manager (pour être sûr ensuite de bien utiliser le bon) et de vérifier dans le fichier configuration.php (avec le bloc-notes ou mieux notepad++) que toutes les infos d'accès à la base sont corrects et correspondent à ce que tu vois dans la page de gestion de la base du Manager.
          Si je comprends bien, tu as fait ça, mais as-tu bien modifié ton fichier de configuration ?
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

          Commentaire


          • #6
            Envoyé par RobertG Voir le message
            Bonjour,

            Tu ne dis pas si le site est accessible ou si c'est seulement l'administration qui est indisponible.
            Si c'est les deux, la première chose serait de restaurer une version de la base antérieure à tes modifications dans phpMyAdmin, de modifier le mot de passe de la base dans le Manager (pour être sûr ensuite de bien utiliser le bon) et de vérifier dans le fichier configuration.php (avec le bloc-notes ou mieux notepad++) que toutes les infos d'accès à la base sont corrects et correspondent à ce que tu vois dans la page de gestion de la base du Manager.
            Si je comprends bien, tu as fait ça, mais as-tu bien modifié ton fichier de configuration ?
            UN GRAND MERCI A TOI RobertG

            Le site et l'admin refonctionnent ... c'était bien le mot de passe erroné, en plus j'avais choisis un mot de passe avec un trait d'union "-" ce qui ne pouvait pas fonctionner.

            Il ne plus me restera qu'à changer la version de PHP, toujours en 5.6.40 et là je flippe un peu ...
            J'ai bien goûté des substances amères
            et nulle ne l'est plus que l'eau de mer,
            c'est pour cela que je préfère la bière

            Commentaire


            • #7
              Si toutes tes extensions sont à jour, tu ne devrais pas avoir de soucis.
              De toute façon, il te suffit de changer la version de PHP dans le fichier .ovhconfig pour revenir via ftp ou depuis le Manager, donc tu ne risques rien.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #8
                Envoyé par RobertG Voir le message
                Si toutes tes extensions sont à jour, tu ne devrais pas avoir de soucis.
                De toute façon, il te suffit de changer la version de PHP dans le fichier .ovhconfig pour revenir via ftp ou depuis le Manager, donc tu ne risques rien.
                Bon ben j'ai mis PHP 7.3 dans le panel OVH, dans l'admin Joomla, il affiche bien 7.3 mais le site affiche une page blanche.


                Dois-je faire autre chose ?

                Edit : l' .ovhconfig affiche bien PHP 7.3 aussi à la racine
                Dernière édition par jeanmarie1778 à 28/04/2021, 10h06
                J'ai bien goûté des substances amères
                et nulle ne l'est plus que l'eau de mer,
                c'est pour cela que je préfère la bière

                Commentaire


                • #9
                  Si le site affiche une page blanche en 7.3, c'est peut-être parce qu'une extension n'est pas compatible avec cette version de PHP.
                  Il faudrait voir en activant le débogage et en mettant le rapport d'erreur au maximum ou à développement si tu obtiens un listing des fichiers par où ça passe avant de provoquer l'erreur, ça permettrait de trouver le fautif.
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                  MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                  Commentaire


                  • #10
                    Envoyé par RobertG Voir le message
                    Si le site affiche une page blanche en 7.3, c'est peut-être parce qu'une extension n'est pas compatible avec cette version de PHP.
                    Il faudrait voir en activant le débogage et en mettant le rapport d'erreur au maximum ou à développement si tu obtiens un listing des fichiers par où ça passe avant de provoquer l'erreur, ça permettrait de trouver le fautif.
                    Oui oui, c'est ce que j'ai fait et j'obtiens pour la partie PHP et autres :

                    J'ai 14 lignes d'erreur concernant aridocsviewer qui pose problème, c'est un plugin system d'origine Joomla non ?

                    Je le désactive mais rien n'y fait


                    Dans les 3 lignes PHP : Obsolète: les méthodes portant le même nom que leur classe ne seront pas des constructeurs dans une future version de PHP; plgSystemAridocsviewer a un constructeur obsolète.
                    J'ai bien goûté des substances amères
                    et nulle ne l'est plus que l'eau de mer,
                    c'est pour cela que je préfère la bière

                    Commentaire


                    • #11
                      Logiquement, si désactivé, il ne devrait plus provoquer d'erreur.
                      Vérifie quand même s'il n'y a pas une version plus récente que la tienne, pendant longtemps ARI ne signalait pas les mises à jour.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                      Commentaire


                      • #12
                        Envoyé par RobertG Voir le message
                        Logiquement, si désactivé, il ne devrait plus provoquer d'erreur.
                        Vérifie quand même s'il n'y a pas une version plus récente que la tienne, pendant longtemps ARI ne signalait pas les mises à jour.
                        Parfait,

                        Effectivement : This extension does NOT implement the Joomla! Update System

                        J'ai désactivé 2-3 autres trucs et ça fonctionne


                        Merci à toi RobertG



                        J'ai bien goûté des substances amères
                        et nulle ne l'est plus que l'eau de mer,
                        c'est pour cela que je préfère la bière

                        Commentaire


                        • #13
                          Si tu vas sur le site Arisoft, il y a une version de 2018 (2.2.1, je crois), mais rien de plus récent.
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                          Commentaire


                          • #14
                            Envoyé par RobertG Voir le message
                            Si tu vas sur le site Arisoft, il y a une version de 2018 (2.2.1, je crois), mais rien de plus récent.
                            Oui j'ai vu mais je ne m'en servais pas de toute façon, merci à toi
                            J'ai bien goûté des substances amères
                            et nulle ne l'est plus que l'eau de mer,
                            c'est pour cela que je préfère la bière

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins

                            Partenaire de l'association

                            Réduire

                            Hébergeur Web PlanetHoster
                            Travaille ...
                            X