Mise en page

Réduire
Ce sujet est fermé.
X
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Mise en page

    Bonjour,

    J'ai fait une mise en page en tab mais j'ai un petit soucis!
    J'ai toutes les tabs qui apparaissent sur une seule!!
    Impossible de savoir ou se trouve mon bug!

    Voici le site en question qui me prend la tête :
    http://www.ideceo.fr/index.php/solutions

    Si vous avez une idée! Je prends tout de suite

    Merci d'avance,
    Bien cordialement,
    Edith Bonamy

  • #2
    Re : Mise en page

    Site en maintenance : impossible de voir la page...
    Pour les tabs, quel plugin a été utilisé ?
    Cordialement,
    Chabi01 - http://www.xlformation.com

    Commentaire


    • #3
      Re : Mise en page

      Bonjour,

      J'ai mis le site en ligne ;-)
      Autant pour moi! C'est le code du template DOOM

      Bien cordialement,

      Commentaire


      • #4
        Re : Mise en page

        Sur Firefox 28 Linux, tes tabs fonctionnent parfaitement : Expertise et conception, Sap N. Bi, Sap Bi IP, SAP BPC, etc...

        Essaye sur différents navigateurs (Lequel utilises-tu ?)
        Chabi01 - http://www.xlformation.com

        Commentaire


        • #5
          Re : Mise en page

          Bonjour,

          Merci pour ta réponse.

          Je suis sous Firefox. En faite elles fonctionnent bien mais quand j'ouvre la première fois la page j'ai tout le contenu des tabs qui appaissents dans une seule. Cela le fait aussi chez mon client! ;-( Je ne sais pas d'ou cela peut venir car en effet lorsque je clique sur un tab par la suite tout fonctionne super bien! Très étrange. Alors je me dis que j'ai mal placer une div mais si c'était le cas les tabs ne seraient pas bonne!

          Vraiment étrange! Non?

          Commentaire


          • #6
            Re : Mise en page

            Testé plusieurs fois...aucun souci de mon côté.
            Vérifie si en vidant ton cache cela solutionne quelque chose : le dernier tab cliqué est gardé en mémoire sur le navigateur..
            Cordialement,
            Chabi01 - http://www.xlformation.com

            Commentaire


            • #7
              Re : Mise en page

              Bonjour hartclip,

              Quand on regarde via "Inspecter l'élément" de Chrome, le code est le suivant :
              Code HTML:
              <div class="tab">
                  <div class="tabbale">
                      <ul id="tab1" class="nav nav-tabs">
                          <li class="active">...</li>
                          <li>...</li>
                          <li>...</li>
                          <li class="active">...</li>
                          <li>...</li>
                          <li>...</li>
                      </ul>
                      <div class="tab-content">
                          <div id="tab1-tab1" class="tab-pane fade active in">...</div>
                          <div id="tab1-tab2" class="tab-pane fade active in">...</div>
                          <div id="tab1-tab3" class="tab-pane fade active in">...</div>
                          <div id="tab1-tab4" class="tab-pane fade active in">...</div>
                          <div id="tab1-tab5" class="tab-pane fade">...</div>
                          <div id="tab1-tab6" class="tab-pane fade">...</div>
                      </div>
                  </div>
              </div>
              Les deux onglets avec class="active" sont "Expertise & Conception" et "SAP BPC". Ce sont ceux qui s'affichent comme ouverts initialement.

              Il faut donc regarder comment enlever le class="active" initial sur "SAP BCP" dans les onglets tabs du template Doom.

              Pour le contenu c'est la même chose on retrouve la class="active" pour les contenus des onglets 1, 2, 3 et 4 en même temps.

              On retrouve le même type de problème sur la page Qui sommes-nous avec les deux onglets "Nos équipes" et "Nous rejoindre" (le 's' est à corriger) et un mélange des quatre contenus qui sont aussi en "active".

              Amicalement,
              Rajoz

              EDIT :
              • Ajout de l'information sur le contenu.
              • Ajout de Qui sommes-nous
              Dernière édition par Rajoz à 30/04/2014, 14h41

              Commentaire


              • #8
                Re : Mise en page

                Bonjour,

                Merci pour votre retour.

                C'est surement cela je vais tester ;-)
                Et je reviens vers vous ;-)

                Commentaire


                • #9
                  Re : Mise en page

                  Bien vu ;-)
                  Il s'agissait bien de classe active c'était tellement évident!!!
                  Encore un grand merci!

                  J'ai un autre problème avec l'image de fond qui ne veux pas changer quand je la charge!
                  Si je modifie le nom dans le css elle disparaît comme il faut!
                  Si je la renomme avec le bon nom dans le fichier des images l'image n’apparait pas!
                  Si je mets la nouvelle image avec le nom de celle d'origine rien ne se passe non plus!
                  Vraiment étrange! c'est bien la 1ère fois que ça m'arrive!

                  C'est cette image : background-image: url("../images/br-bg.png");
                  Elle est dans les onglets de menus : solution, conseil, qui sommes-nous ...

                  Encore un grand merci pour votre aide ;-)

                  Bien cordialement,
                  Edith Bonamy

                  Commentaire


                  • #10
                    Re : Mise en page

                    Bonjour Edith,

                    J'imagine qu'il s'agit de l'image dont j'ai trouvé le CSS dans template.css aux environs de la ligne 466 :
                    Code:
                    #sp-breadcrumb-wrapper {
                      background-size: 100% 100% !important;
                      margin-bottom: -100px;
                      background: url(../images/br-bg.png) no-repeat 0 0;
                      padding: 80px;
                      text-align: center;
                    }
                    Normalement en chargeant une image par exemple monbackground.png dans le dossier images comme br-bg.png et en modifiant le nom dans le CSS (background: url(../images/monbackground.png) no-repeat 0 0; ), la nouvelle image devrait s'afficher.

                    Par contre quand on charge une nouvelle image en lui donnant le nom d'origine br-bg.png et donc sans modifier le CSS, le cache à qui on demande la même chose va continuer de fournir l'ancienne image. C'est peut-être ce qui se passe.

                    La première chose à faire c'est de vider les caches de Joomla! et du navigateur pour voir si l'image qui s'affiche correspond bien à celle dont le fichier est chargé dans le dossier images et dont le nom est dans le CSS.

                    Amicalement,
                    Rajoz

                    EDIT : Je ne l'ai pas précisé mais quand je parle du dossier images, il s'agit du dossier du template (templates/rox_doom/images) pas de celui qui se trouve à la racine du site Joomla!.
                    Dernière édition par Rajoz à 30/04/2014, 19h13

                    Commentaire


                    • #11
                      Re : Mise en page

                      Merci c'est parfait ;-)
                      J'étais dans le mauvais dossier ;-)

                      Bonne soirée,
                      Bien cordialement,
                      Edith Bonamy

                      Commentaire


                      • #12
                        Re : Mise en page

                        Problème résolu alors ?
                        Chabi01 - http://www.xlformation.com

                        Commentaire


                        • #13
                          Re : Mise en page

                          Oui tout ah fait ;-)
                          Je vais mettre le poste en résolu d'ailleurs!

                          Bonne journée de 1er Mai ;-)

                          Commentaire


                          • #14
                            Re : Mise en page

                            Merci à Rajoz pour sa participation
                            Cordialement,
                            Chabi01 - http://www.xlformation.com

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X