Fil d'ariane qui s'affiche pas correctement

Réduire
Ce sujet est fermé.
X
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Fil d'ariane qui s'affiche pas correctement

    Bonjour, j'ai un petit problème avec mon fil d'ariane.

    Voila, j'ai un menu avec la rubrique "magasins" et 2 sous rubriques "lunel" "avignon".

    j'ai créé un article pour la rubrique "magasins" avec une liste déroulante offrant aux utilisateurs la possibilité de choisir la ville de leur magasin, Lunel ou Avignon.

    Lorsque l'on choisit "Avignon" dans la liste cela nous amène sur l'article "Avignon" et le fil d'ariane affiche les infos parfaitement accueil>Magasin>Avignon
    Mais lorsque l'on sélectionne "Lunel" le fil d'ariane ne s'affiche plus. Pourtant lorsque l'on passa par le menu principal pour afficher l'article "Lunel", le fil d'ariane s'affiche correctement.

    Je n'arrive pas à comprendre pourquoi.

    Merci d'avance pour voter aide

  • #2
    Re : Fil d'ariane qui s'affiche pas correctement

    Envoyé par mela Voir le message
    Bonjour, j'ai un petit problème avec mon fil d'ariane.

    Voila, j'ai un menu avec la rubrique "magasins" et 2 sous rubriques "lunel" "avignon".

    j'ai créé un article pour la rubrique "magasins" avec une liste déroulante offrant aux utilisateurs la possibilité de choisir la ville de leur magasin, Lunel ou Avignon.

    Lorsque l'on choisit "Avignon" dans la liste cela nous amène sur l'article "Avignon" et le fil d'ariane affiche les infos parfaitement accueil>Magasin>Avignon
    Mais lorsque l'on sélectionne "Lunel" le fil d'ariane ne s'affiche plus. Pourtant lorsque l'on passa par le menu principal pour afficher l'article "Lunel", le fil d'ariane s'affiche correctement.

    Je n'arrive pas à comprendre pourquoi.

    Merci d'avance pour voter aide
    Bonjour,

    Peux tu nous envoyer l'adresse de ton site ?
    (ça doit être le soleil de lunel qui fait ça, car à nimes tout vas bien avec les fils d'ariane )
    Folcomedia - Agence Web
    Développeur Joomla depuis 1724
    http://www.folcomedia.fr
    Sites internet | E-commerce | Hébergement | Application mobiles & Facebook
    Présent au JoomlaDay 2014

    Commentaire


    • #3
      Re : Fil d'ariane qui s'affiche pas correctement

      Effectivement ça doit être la chaleur qui perturbe mon fil d'ariane (ou bien moi)

      Par contre, je peux pas mettre l'adresse, car je travaille encore en local.

      Mais j'ai fait des screenShots. Même si je pense que ça va pas être trop utile.
      Article pour selectionner : Cliquez sur l'image pour l'afficher en taille normale

Nom : Sans-titre-1.jpg 
Affichages : 1 
Taille : 26,0 Ko 
ID : 1802928
      Version Avignon : Cliquez sur l'image pour l'afficher en taille normale

Nom : avignon.jpg 
Affichages : 1 
Taille : 40,1 Ko 
ID : 1802929
      Version Lunel : Cliquez sur l'image pour l'afficher en taille normale

Nom : version-sans-fa.jpg 
Affichages : 1 
Taille : 29,3 Ko 
ID : 1802930
      Version Lunel en passant par le menu : Cliquez sur l'image pour l'afficher en taille normale

Nom : lunel-fil-ariane.jpg 
Affichages : 1 
Taille : 40,9 Ko 
ID : 1802931

      Ce qui est le plus fous c'est que l'article d'avignon est le copier coller de celui de Lunel. Et j'ai strictement modifier.

      Commentaire


      • #4
        Re : Fil d'ariane qui s'affiche pas correctement

        Comment tu fais pour passer de la version Avignon à la version Lunel sans passer par le menu ?
        Folcomedia - Agence Web
        Développeur Joomla depuis 1724
        http://www.folcomedia.fr
        Sites internet | E-commerce | Hébergement | Application mobiles & Facebook
        Présent au JoomlaDay 2014

        Commentaire


        • #5
          Re : Fil d'ariane qui s'affiche pas correctement

          Désolée, je ne voyais pas les images, lorsque j'ai mis les intitulés. Donc image 1 = sélection par la liste. Cette image est accessible en cliquant directement sur "magasin" dans le menu. Image 2 = Article "Avignon" par l’accès de la liste. Image 3 = article "Lunel" par l’accès de la liste. Image 4 = article "Lunel" accès directement par le menu.


          Il y a deux façon d’accéder aux articles "Avignon" et "Lunel". Soit en passant directement par le menu (qui est déroulant) soit par la page de sélection (la 1ère image).

          Commentaire


          • #6
            Re : Fil d'ariane qui s'affiche pas correctement

            Envoyé par mela Voir le message
            Désolée, je ne voyais pas les images, lorsque j'ai mis les intitulés. Donc image 1 = sélection par la liste. Cette image est accessible en cliquant directement sur "magasin" dans le menu. Image 2 = Article "Avignon" par l’accès de la liste. Image 3 = article "Lunel" par l’accès de la liste. Image 4 = article "Lunel" accès directement par le menu.


            Il y a deux façon d’accéder aux articles "Avignon" et "Lunel". Soit en passant directement par le menu (qui est déroulant) soit par la page de sélection (la 1ère image).
            D'accord, la liste déroulante c'est toi qui l'a développé ou c'est un composant ?
            Folcomedia - Agence Web
            Développeur Joomla depuis 1724
            http://www.folcomedia.fr
            Sites internet | E-commerce | Hébergement | Application mobiles & Facebook
            Présent au JoomlaDay 2014

            Commentaire


            • #7
              Re : Fil d'ariane qui s'affiche pas correctement

              Développée. Voici le code :
              <select name="choix" onchange="window.location.href=this.value">
              <option id="choix0" selected="selected" value="choix0">Choissiez voter magasin</option>
              <option id="choix1" value="index.php?option=com_content&amp;view=artic le&amp;id=75:choix-vert-avignon&amp;catid=80:magasins&amp;Itemid=539">Avig non</option>
              <option id="choix2" value="index.php?option=com_content&amp;view=artic le&amp;id=71:lunel-viel&amp;catid=80:magasins&amp;Itemid=444">Lunel Viel</option>
              </select>

              Commentaire


              • #8
                Re : Fil d'ariane qui s'affiche pas correctement

                Envoyé par mela Voir le message
                Développée. Voici le code :
                <select name="choix" onchange="window.location.href=this.value">
                <option id="choix0" selected="selected" value="choix0">Choissiez voter magasin</option>
                <option id="choix1" value="index.php?option=com_content&view=article&i d=75:choix-vert-avignon&catid=80:magasins&Itemid=539">Avignon</option>
                <option id="choix2" value="index.php?option=com_content&view=article&i d=71:lunel-viel&catid=80:magasins&Itemid=444">Lunel Viel</option>
                </select>
                Alors plsuieurs questions:

                1/ Est ce que les espaces dans "view=artic le" est normal ?
                2/ Ton menu Item 444 renvoi bien sur le menu ou l'article de lunel est affiché ?
                Folcomedia - Agence Web
                Développeur Joomla depuis 1724
                http://www.folcomedia.fr
                Sites internet | E-commerce | Hébergement | Application mobiles & Facebook
                Présent au JoomlaDay 2014

                Commentaire


                • #9
                  Re : Fil d'ariane qui s'affiche pas correctement

                  Concernant les espaces, j'utilise l'éditeur en mode classique pour insérer les liens. Car je ne connais par coeur l'itilué des URL. Donc j'ai les espaces ou les & se sont mis automatiquement. Et après je passe en mode éditeur html.

                  Et j'avoue que intitulé item j'ai pas très bien compris à quoi ça correspondait.

                  Commentaire


                  • #10
                    Re : Fil d'ariane qui s'affiche pas correctement

                    C'est bon j'ai compris à quoi correspondait l'item et j'ai réglé le problème. L'item du menu ne correspondait pas à celui de l'article.

                    Merci pour l'information

                    Commentaire


                    • #11
                      Re : Fil d'ariane qui s'affiche pas correctement

                      Envoyé par mela Voir le message
                      Concernant les espaces, j'utilise l'éditeur en mode classique pour insérer les liens. Car je ne connais par coeur l'itilué des URL. Donc j'ai les espaces ou les & se sont mis automatiquement. Et après je passe en mode éditeur html.

                      Et j'avoue que intitulé item j'ai pas très bien compris à quoi ça correspondait.
                      En faite le itemID c'est l'ID de ton menu.

                      Tu peux me coller les 2 urls, une fois quand tu passes par le menu et l'autre quand tu passes par la liste déroulante pour le magasin de lunel.
                      Folcomedia - Agence Web
                      Développeur Joomla depuis 1724
                      http://www.folcomedia.fr
                      Sites internet | E-commerce | Hébergement | Application mobiles & Facebook
                      Présent au JoomlaDay 2014

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins

                      Partenaire de l'association

                      Réduire

                      Hébergeur Web PlanetHoster
                      Travaille ...
                      X