Pas d'accès à la page administration de mon site

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Pas d'accès à la page administration de mon site

    Bonjour et merci pour votre super site qui est une vraie mine.
    Si je ne suis pas dans la bonne section veuillez m'en excuser.

    Je me permets de poster car j'ai un problème qui je pense doit être simple mais qui ne me saute pas aux yeux.
    J'ai un site qui fonctionne parfaitement depuis plusieurs mois/année...
    Je me suis mis en tête de faire les mise à jour car de temps en temps ce n'est pas une si mauvaise idée
    Pour après migrer sur un poste plus récent niveau PC.
    Je tourne sous windows 7 avec xamp en version 3.2.2

    Mais mon problème proviens du fait que la page administrateur n'apparaît pas quand je tape www.monsite.com/administrator.
    Il me renvoie sur www.monsite.com...

    J'ai cherché un moment et je me suis aperçu que j'ai à peu près le même problème avec phpmyadmin qui ne me donne pas l'accès.

    J'ai donc voulu vérifier des problèmes potentiels de mots de passes vers la bdd mais j'arrive à accéder à mysql en ligne de commande et quand je change les mots de passes le site me dit qu'il ne peut pas se connecter à mysql ce qui est logique.

    Donc le site tourne, mysql tourne mais je ne peux pas accéder aux outils d’administration phpmyadmin et joomla.
    Je soupçonne apache...

    Merci d'avance pour votre aide
    Dernière édition par secalex à 19/09/2018, 13h33

  • #2
    Bonjour et bienvenue,

    SI j'ai bien compris, vous avez installé votre site en local.
    Dans ce cas, l'URL doit être localhost/dossier_du_site/administrator

    Pour PHPMyAdmin, ce doit être http://localhost/mysql/
    Je n'ai pas de xamp sous la souris pour être sûr
    Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
    ---
    UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
    bgMax
    , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

    Commentaire


    • #3
      Merci pour votre réponse.
      J'ai effectivement oublié de préciser qu'en local je n'y accède pas non plus.
      Et l'accès à phpmyadmin est bien limité au domaine local.
      Par contre je devrai pouvoir accéder à l'administration de joomla de n'importe où mais en local ou en distant ça ne marche pas.

      Commentaire


      • #4
        Bonjour,

        Vous avez fait la mise à jour où : en local, en distant, les 2 ?
        S'il est en distant, quel est l'hébergeur ?

        Si le site est hébergé, le mieux est de fournir l'URL
        Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
        ---
        UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
        bgMax
        , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

        Commentaire


        • #5
          Pour l'instant je n'ai pas fait de MAJ car je n'ai pas d'accès.
          Le site est hébergé sur un serveur en local.

          Commentaire


          • #6
            Le site est hébergé sur un serveur en local.
            Vous voulez dire que votre site est auto-hébergé ?

            Pourriez-vous être plus précis et fournir des informations techniques sur le serveur local ?
            Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
            ---
            UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
            bgMax
            , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

            Commentaire


            • #7
              Désolé si je ne suis pas clair

              Le site est effectivement hébergé en interne sur un des mes PC.
              Le PC tourne sous windows 7 et ne sert qu'à ça.
              Et il n'a rien de particulier.

              J'ai donc accès à la machine et même sur cette machine je n'ai pas d'accès à la page administrator de joomla et de phpmyadmin.
              Par contre j'ai pu tester mysql qui tourne sans problème.
              Le site en lui-même fonctionne d'ailleurs très bien...

              Merci pour votre aide

              Commentaire


              • #8
                Désolé si je ne suis pas clair
                C'est le moins qu'on puisse dire

                Si vous ne répondez pas aux questions, il faudra chercher par vous-même
                Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
                ---
                UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
                bgMax
                , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

                Commentaire


                • #9
                  Le PC sur lequel tourne le site internet est un DELL Vostro 3546 qui tourne sous Windows 7 pro.
                  La connexion réseau se fait via la connexion Ethernet et le Wifi est désactivé.
                  Il y a un antivirus avast mais le problème ne semble pas venir de lui (je l'ai désactivé pour voir et ça n'a rien changé).
                  J'ai les droit administrateur sur le PC et il est intégré à notre domaine.
                  Et il ne sert qu'au site internet et tous les logiciels superflus ont été enlevés.

                  Voilà ce que je peux dire sur le hardware de la bête.

                  Commentaire


                  • #10
                    As-tu vérifié le .htaccess ? Il ne contiendrait pas des redirections un peu trop ... directives ?
                    Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
                    C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
                    Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

                    Commentaire


                    • #11
                      Bonsoir,

                      La config du PC a une importance relative
                      Ce que l'on aurait besoin de savoir, c'est la configuration du serveur et la gestion des DNS pour le nom de domaine
                      Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
                      ---
                      UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
                      bgMax
                      , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

                      Commentaire


                      • #12
                        Bonjour,
                        Désolé pour ma réponse tardive.

                        Entre temps j'ai un peu avancé et surtout reproduit mon problème.
                        Pour éviter de casser ce qui est fonctionnel pour le moment, j'ai tenté de réinstallé le site sur un autre pc.

                        J'ai réinstallé la même version de xampp sans problème.
                        J'ai ensuite installé joomla sans problème avec accès au back-end à la fin de l'installation.

                        J'ai ensuite restauré les sauvegardes faites avec akeeba sur le PC dédié à ce test et à partir de là plus de back-end.

                        Commentaire


                        • #13
                          Bonjour,
                          J'ai ensuite installé joomla sans problème avec accès au back-end à la fin de l'installation.
                          Pourquoi installer Joomla si tu comptais restaurer une sauvegarde Akeeba Backup

                          Comment tu t'y prends exactement ... détaille nous bien tes actions sinon on arrivera pas a comprendre ce que tu tentes de faire !
                          “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
                          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                          Commentaire


                          • #14
                            Je vais passer sur l'installation de xampp qui n'apporte rien.

                            Après l'install de xampp j'ai tout d'abord fait une restauration de mon site avec kickstart qui m'a mis au même point que précédemment sans accès au back end.
                            Aucun problème et aucunes erreurs lors des différentes phases.

                            Je me suis donc dit qu'il fallait que je réinstalle joomla avant pour que le back end puisse fonctionner.
                            J'ai donc tout désinstaller (même xampp), un coup de ccleaner puis j'ai résintallé xampp, puis joomla (sans problème avec accès back end) puis restauration avec kickstart pour arriver au même point de nouveau...
                            Aucun problème et aucunes erreurs lors des différentes phases.

                            Commentaire


                            • #15
                              ok, donc il y a quelque chose qui bloque le backend de ta sauvegarde ... un fichier htaccess par exemple ? ou une protection quelquonque ?
                              Car c'est souvent ce dossier qui est le plus protégé

                              Par contre, j'ai une question : Cette sauvegarde provient bien d'un site qui fonctionne correctement en ligne ? Si oui, donne nous son url
                              “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
                              Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X