Error 500

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Error 500

    Bonjour,

    Mon site www.admlarochelle.com joomla 3.9.2 est en error 500 depuis hier soir. C'est un serveur mutualisé chez online. L'accès à l'administration fonctionne bien, mon fichier htaccess n'a pas changé depuis janvier 2018, j'ai changé de template, mais même chose ... Si je passe le site en maintenance, je n'ai plus error 500.

    Je suis sec et je vous demande de l'aide merci,
    Cordialement,
    Dernière édition par phelibre à 29/01/2019, 14h40

  • #2
    Bonjour,

    Essayez de passer votre site en mode debug : https://kb.joomla.fr/procedures/debu...-developpement

    Cela permettra de voir quelle extension a des problèmes.

    Pascal
    Les JoomlaDays Paris 2019, c'était du 8 au 9 mars... J'y étais et vous ?

    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Merci, c'est fait ... Je n'ai pas de problème pour afficher sur le navigateur la dernière newsletter ici comme pour dateheure.php sur la racine ...
      J'ai sollicité l'aide mais je ne sais pas ou je vais trouver les fichiers créés du mode bug ?

      Pierre,
      Réseau de distribution associatif et militant, Artisans du Monde La Rochelle défend une vision engagée du commerce équitable.Vendre, informer, sensibiliser faire pression.
      Dernière édition par phelibre à 28/01/2019, 10h45

      Commentaire


      • #4
        Finalement je l'ai désactivé car je ne vois pas de trace de la partie front end ! J'ai l'impression que le mode debug concerne la partie back end qui n'a pas de problème !
        Je me trompe ?

        Cordialement,

        Commentaire


        • #5
          Il faut passer le rapport d'erreur à "Développement" ou "Maximum" et les informations s'afficheront sur la page de votre explorateur.

          Sinon, vous devez regarder dans les logs APACHE chez votre hébergeur. En général, c'est prévu au niveau du CPanel de votre compte chez Online.

          Pascal
          Dernière édition par manu93fr à 28/01/2019, 12h28
          Les JoomlaDays Paris 2019, c'était du 8 au 9 mars... J'y étais et vous ?

          If anything can go wrong, it will...
          If I can help, I will ..https://conseilgouz.com

          Commentaire


          • #6
            Tu peux tenter de dépublier quelques modules, au hasard, en privilégiant ceux qui ne sont pas natifs de joomla.

            Le mieux reste de consulter les logs de ton site.

            Tu es en mutualisé, tu peux demander de l'aide à ton hébergeur, pour obtenir les logs de ton site, pour identifier la ou les erreurs qui font planter le site.

            Commentaire


            • #7
              Finalement j'ai trouvé error.log dans lequel j'ai :

              #LogCenter file last modification: 2019-01-28 15:03:54
              apache2[4]: [fastcgi:error] [pid 4:tid 139948413937408] [client 86.254.47.41:52882] FastCGI: comm with server "/fast-cgi-real-php7-1" aborted: idle timeout (120 sec)
              apache2[4]: [fastcgi:error] [pid 4:tid 139948413937408] [client 86.254.47.41:52882] FastCGI: incomplete headers (0 bytes) received from server "/fast-cgi-real-php7-1"
              apache2[4]: [fastcgi:error] [pid 4:tid 139948422330112] [client 86.254.47.41:41988] FastCGI: comm with server "/fast-cgi-real-php7-1" aborted: idle timeout (120 sec)
              apache2[4]: [fastcgi:error] [pid 4:tid 139948422330112] [client 86.254.47.41:41988] FastCGI: incomplete headers (0 bytes) received from server "/fast-cgi-real-php7-1"
              apache2[4]: [fastcgi:error] [pid 4:tid 139948380366592] [client 178.255.215.66:33961] FastCGI: comm with server "/fast-cgi-real-php7-1" aborted: idle timeout (120 sec)
              apache2[4]: [fastcgi:error] [pid 4:tid 139948380366592] [client 178.255.215.66:33961] FastCGI: incomplete headers (0 bytes) received from server "/fast-cgi-real-php7-1"

              Vous en pensez quoi ? C'est côté online, non !
              Merci,

              Commentaire


              • #8
                On dirait que ton site va chercher des infos sur un autre serveur qui ne répond pas.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                Commentaire


                • #9
                  Oui je confirme, je viens de réactiver le module et bravo plus d'erreur 500
                  C'est un fil d'actualité ici http://www.artisansdumonde.org/actua...ng=fr&type=rss

                  Comment avez-vous pu voir ce flux ? Sachant qu'il y avait une erreur 500

                  Merci,
                  Dernière édition par phelibre à 28/01/2019, 17h41

                  Commentaire


                  • #10
                    Si la question s'adresse à moi, je n'ai fait que supposer que c'était un appel à un serveur externe qui ne répondait pas en voyant " comm with server "/fast-cgi-real-php7-1" aborted: idle timeout (120 sec)"
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                    Commentaire


                    • #11
                      Ah ! le metier donc

                      Malgré tout ce flux RSS fonctionne, je l'ai testé depuis Opéra par exemple ...
                      Avez-vous une idée pourquoi ce flux provoque un timeout chez Online ?

                      Merci,

                      Commentaire


                      • #12
                        Peut être le même problème que moi, ton site n'est pas assez costaud en performance, ram notamment ?
                        De ce fait, si ton site doit afficher des ressources externes, il fatigue lors des requêtes, qui plus est, si il est visité par de nombreux bots ( légitimes, ou non. ) ce qui augmente la charge pour le serveur. Je peux me tromper, c'est peut être un autre problème, les chemins obscurs étant nombreux pour administrer un serveur web.

                        Commentaire


                        • #13
                          Finalement depuis un Mac mini en local qui me sert de test, j'ai installé la sauvegarde de janvier et j'ai remarqué que le flux fonctionnait bien avec un affichage rapide ...
                          Ce matin j'ai réactivé ce flux sur le serveur dédié Online, et plus d'erreur 500 !

                          J'ai contacté Online pour avoir un semblant d'explication, je n'ai rien obtenu

                          Encore merci pour vos aides,

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins

                          Partenaire de l'association

                          Réduire

                          Hébergeur Web PlanetHoster
                          Travaille ...
                          X