débusquer ce php.ini sur serveur ionos ( uk )

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] débusquer ce php.ini sur serveur ionos ( uk )

    Bonjour à tous,

    après plusieurs recherches sur forums francophones et anglophones, je m'en remet au forum pour j'en suis sur trouver la solution.

    Suite à un message d'erreur survenant sur le site suite à un mauvais log

    Fatal error: Allowed memory size of 83886080 bytes exhausted (tried to allocate 58908672 bytes) in /homepages/35/d765144243/htdocs/clickandbuilds/Joomla/LA_Circum/libraries/vendor/joomla/image/src/Image.php on line 705

    Je décide de modifier mon php.ini, je vais donc dans php information et il m'indique l'adresse suivante etc/php7.3/php.ini

    je fouille ici:

    clickandbuild/joomla/monsite/(je ne trouve pas le dossier)

    Seulement j'ai beau fouiller partout, je ne trouve pas ce satané dossier etc et donc pas moyens de mettre la main sur mon php.ini

    J'ai contacté ionos (en uk) ils maintiennent que je peux y accéder mais je ne sais pas où est ce dossier.

    J'ai laissé des screen pour mieux comprendre.

    merci d'avance.

  • #2
    Salut

    /etc est un dossier en dehors de ton site. En général, ton site est stocké dans un dossier tel que p.ex. /public_html/ ou /www.
    Ici /etc est donc un dossier à la racine de ton hébergement. Ton écran FTP montre que tu n'es pas au bon endroit.

    Voir dans le cpanel de ton hébergeur si tu peux y accéder.

    Note : leur façon de t'aider est interpellante; est-ce cela du "support" ? J'espère que c'est un hébergeur gratuit
    Christophe (cavo789)
    Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
    Mes logiciels OpenSource : https://www.avonture.be

    Commentaire


    • #3
      Bonsoir,

      En mutualisé chez 1&1, on peut ajouter soi-même un php.ini à la racine et il y a en principe dans leur doc un script permettant de le recopier dans tous les dossiers du site. En tout cas, l'assistance française en a elle-même placé un sur le site d'une amie, mais pour une augmentation de upload_max_filesize.
      Par contre, pas sûr qu'il permette d'augmenter la mémoire.
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

      Commentaire


      • #4
        Salut, merci pour vos messages.

        Je suis embêté car même dans la racine du site je ne trouve pas ce dossier.

        A la racine du serveur j'ai mes deux sites dans clickandbuild et dans log j'ai plein de fichiers access log ect mai pas de php.ini

        ---------------------Est ce que je peux créer un contre fichier php.ini que je mettrai moi même à la racine ?

        Leur support, non sans rire voici ce qu'ils m'ont écris: il s'agit de ionos angleterre haha

        You can edit or download php.ini file via Webspace in your 1&1 Control Panel. Once you are logged in click Hosting then Use Webspace, access the folder where your php.ini file located then right click and choose download. After you have downloaded the file, you can modify it using a word editor like Notepad then re-upload it to your webspace.

        My colleagues and I will be happy to help you with any questions you may have about your products.
        Dernière édition par lotfay à 07/03/2019, 09h49

        Commentaire


        • #5
          Il n'y a pas de php.ini par défaut sur un mutualisé, contrairement à ce qui t'a été répondu.
          Il faut le créer toi-même avec les instructions qu vont bien, et en principe (ce n'est pas toujours vrai), le copier dans tous les dossiers comme je l'ai dit plus haut.
          Je viens de trouver cette page : https://www.ionos.fr/assistance/hebe...s-je-modifier/
          et celle-ci https://www.ionos.fr/assistance/hebe...hp-via-phpini/
          A voir si ça fonctionne de la même manière pour les serveurs UK.
          Dernière édition par RobertG à 07/03/2019, 09h38
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

          Commentaire


          • #6
            Merci RobertG, malheureusement le problème reste inchangé car je dois charger mon php.ini maison dans le répertoire dedié que je ne trouve pas, le fameux etc..

            Commentaire


            • #7
              Non, comme je l'ai dit plus haut, c'est à la racine du site (dans son propre dossier) qu'il faut le placer. Le répertoire "etc" est hors d'accès sur les mutualisés.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

              Commentaire


              • #8
                ça se tente, si je comprends bien dans la racine de mon site je crée le repertoire php et j'y mets mon php.ini dedans ? ou alors j'y mets directement mon php.ini à la racine ?

                Commentaire


                • #9
                  As-tu lu cette page dont je t'ai donné l'adresse tout à l'heure ? https://www.ionos.fr/assistance/hebe...hp-via-phpini/
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                  MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                  Commentaire


                  • #10
                    Oui, et je viens de le relire, il parlent de répertoire du script mais je comprends pas ce qu'il est exactement, ou si je dois créer un nouveau dossier et si oui comment le nommer et si non comment s'appelle ce répertoire script.

                    Commentaire


                    • #11
                      Tu enregistres directement ton nouveau fichier nommé "php.ini" à la racine du site (au même niveau que robots.txt et configuration.php).
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                      Commentaire


                      • #12
                        Il semble que je ne sois pas loin de la vérité, puisque le php.ini que j'ai déposé à la racine du site semble être pris en compte. Seulement, plu moyens d'accèder au site comme montré dans l'image jointe.
                        Error 500 - Internal server error

                        An internal server error has occured!
                        Please try again later.

                        Voici ce que contient mon php.ini edité avec notepad++ sous window 7

                        allow_url_fopen = On
                        display_errors = On
                        safe_mode = On
                        memory_limit = 256M
                        post_max_size = 64M
                        upload_max_filesize = 10M
                        max_execution_time = 60
                        zlib.output_compression = désactivé
                        session.auto_start = off
                        max_input_vars = 5000
                        max_input_time = -1

                        Qu'est ce que j'ai mal fait ? Je m'interroge. Merci

                        Fichiers joints

                        Commentaire


                        • #13
                          A priori, ton erreur étant au niveau de la consommation de mémoire, tu ne devrais avoir à toucher qu'à "memory_limit"
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                          Commentaire


                          • #14
                            Ton php.ini utilise le mot "désactivé"; je ne crois pas que ce soit le mot en français qu'il faut utiliser. "disabled" me semblerait plus opportun ;-)
                            Christophe (cavo789)
                            Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
                            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                            Mes logiciels OpenSource : https://www.avonture.be

                            Commentaire


                            • #15
                              J'ai complètement supprimé les lignes qui me parraissaient inutiles ( en fait celles auxquelles j'y comprends rien et qui me semble pas nécessaire de modifier dans la config par défaut )

                              Le site démarre, le bug qui me dérrangeait n'est plus là, MAIS, le site m'annonce un nouveau message d'erreur en banière, et c'est pas sexy du tout. (mon site lacircum.com)

                              Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /homepages/35/d765144243/htdocs/clickandbuilds/Joomla/LA_Circum/plugins/system/helix3/core/classes/menu.php on line 89

                              En me rendant dans l'administration du site sur php information le chemin d'accès au php.ini reste inchangé avec cette manière de faire je court circuite la config par défaut ?

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X