Joomla 4 RC5 et Joomla 3.10 RC1 sont disponibles.

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Joomla 4 RC5 et Joomla 3.10 RC1 sont disponibles.

    Comme prévu, Joomla 3.10 vient de basculer en version RC et sortira simultanément en version stable avec Joomla 4.0,

    Joomla 3.10 portera le nom de code Daraja, qui signifie pont en swahili.

    Nous espérons qu'il s'agira du pont du bonheur pour la communauté Joomla !
    Cliquez sur l'image pour l'afficher en taille normale

Nom : joomla4-400-rc.jpg 
Affichages : 287 
Taille : 35,4 Ko 
ID : 2029416




    La traduction de l'annonce en français est disponible sur le portail joomla.fr :

    Le projet Joomla! est heureux d'annoncer la disponibilité de Joomla! CMS 4.0 Release Candidate 5 et Joomla 3.10 RC 1. Les utilisateurs de Joomla et les développeurs d'extensions sont invités à té...


    Jeff71 aime ceci.
    Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

  • #2
    Merci Yann !

    Pour info : Akeeba backup 8.0.7 et 8.0.8 posent un problème au niveau de la gestion du calendrier dans la page de gestion des sauvegardes sous Joomla! 4RC5 et 4RC6dev
    Interrogé, Nicholas a répondu qu'il n'y a plus de prise en compte des bugs de cette version 8 pour Joomla! 4 (et PHP 8) et qu'une version 9 spécifique à Joomla! 4 sera disponible.
    L'ennui est que tester sans le secours des sauvegardes Akeeba va être bien compliqué en attendant !

    Sinon, aucun autre problème lors de migration de RC4 à RC5 ou de RC5-dev à RC6-dev.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

    Commentaire


    • #3
      Merci pour ton retour !

      Concernant Nicholas, je ne doute pas que la prochaine version d'akeeba backup pour joomla 4 sera disponible rapidement.

      les version RC et surtout les versions dev étant des versions de tests indépendants, je ne sais pas si la migration des RC sera véritablement maintenue.
      Les priorités étant de respecter le délai pour sortir la version stable fin aout 2021 mais ce n'est qu'un avis, n'hésite pas à faire remonter les infos.

      De mon coté, je vérifie que les sites de mes clients puissent migrer notamment avec leurs anciens templates et extensions, il faut que j'estime la charge de travail que cela représente.
      Le but étant de profiter des dernières fonctionnalités de Joomla 4 ! Ce n'est pas si simple quand certains sites n'ont pas évolué depuis des années, profitant de la compatibilité et la maturité de joomla 3. Il s'agit aussi d'assurer la compatibilité avec php 8 donc double effort !

      Parfois, j'ai bien envie de repartir à zéro afin d'éliminer jquery et d'utiliser pleinement bs5.

      De plus, tu as désormais la 1ere version RC de Joomla 3.10 donc l'occasion de tester un peu plus le pre-check


      Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

      Commentaire


      • #4
        Je teste depuis pas mal de temps, mais comme je l'ai dit précédemment dans d'autres discussions, ce pre-check me pose problème, que ce soit en 3.10 vers 3.10 ou 4 vers 4, pour la définition des manifestes concernant les mise à jour, surtout au niveau des plugins.
        Des extensions parfaitement compatibles 4 sont en alerte dans cette vérification pour le passage en 4, voire d'une 4RC à la suivante.

        Je me suis aussi posé la question de repartir de zéro ou presque en important les données dans un nouveau site avec une extension comme JMigrator.

        J'ai testé une première fois probablement vers une RC4 le passage de mon site de photos, mais immédiatement été bloqué par le template (JoomSpirit) et l'absence de templates compatibles J! 4 alors, en dehors de Cassiopeia. Je ne crois pas avoir listé les extensions incompatibles.
        Je viens de voir que JoomlaPlates propose déjà 30 templates compatibles 3 et 4. Je n'ai pas cherché si d'autres en proposent. Je dois tester Helix Ultimate 2 RC2, mais la nécessité d'abonnement complémentaire à SP Page Builder Pro m'ennuie pour proposer un template basé sur Helix à des clients...
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

        Commentaire


        • #5
          Bonjour De mon côté migration sans soucis de la RC4 -> RC5 qui comporte quelques thèmes et une dizaine d'extensions favorites Il m'a demandé au préalable de mettre à jour le paquet de langue français rc4 et akeeba 8.0.8 je constate simplement que toutes les extensions n'ont pas à priori insérer de notification de leurs mises à jour dans le tableau de bord de joomla: acymailing, tassos ... (je vais faire la maj prochainement) j'ai une notice d'erreur dans une table de dpcalendar qui n'est pas corrigé mais à part cela tout roule ;-)
          Faciliter l'adoption du meilleur du Libre auprès du grand public https://clibre.eu/ - Connaissez-vous des communicants ... pour promouvoir joomla ? https://forum.joomla.fr/forum/th%C3%...mouvoir-joomla

          Commentaire


          • #6
            Au fait, un rappel pour ceux qui testent sur des bases MariaDB : impossible d'installer les version 3.9, 3.10 et 4 sur les versions 10.5 et supérieures de MariaDB en raison du "row format" défini à "compact" (qu'il faut changer en" dynamic') alors que ce format défini également à compact ne pose aucun problème avec MySQL 8 !
            J'ai ouvert une discussion sur Github et il semblerait que les pré-requis vont désormais exiger ce format sur les bases MariaDB, mais qu'en feront les hébergeurs mutualisés ???
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
            MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

            Commentaire


            • #7
              Pour Akeeba, il s'agit en fait d'un bug de la RC5 finale touchant aussi d'autres extensions.
              Correctif, voir https://github.com/joomla/joomla-cms/pull/34949
              daneel et pmleconte aiment ceci.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

              Commentaire


              • #8
                Hello, voici la 1ère version installable de Joomla 4 en français, la RC5 : https://www.joomla.fr/.../Joomla_4.0.0-rc5-Release...
                Je vous serai reconnaissant de la tester et de me faire des retours avant que je la publie officiellement sur Joomla.fr, merci

                Je proposerai dans la semaine qui vient la version en français de Joomla 3.10 qui servira à migrer vers la version 4





                manu93fr et RobertG aiment ceci.
                Support FR de l'éditeur JCE: télécharger JCE en français, aide & forum - www.sarki.ch/jce

                Commentaire

                Annonce

                Réduire
                Aucune annonce pour le moment.

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X