Joomla 4 beta 3 et Joomla 3.10 alpha 1

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Joomla 4 beta 3 et Joomla 3.10 alpha 1

    Bonsoir,

    La version beta 3 de Joomla 4.0 vient de sortir.

    En même temps, sortie de la version alpha 1 de Joomla 3.10. Pour rappel, la version 3.10 sert de pont entre la version 3.9 et la version 4.0.

    Pour plus d'informations: https://www.joomla.org/announcements...10-alpha1.html

    Bons tests,

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    JoomlaDays, 2 et 3 Octobre. Plus d'infos sur https://www.joomladay.fr

  • #2
    Avec le lien vers Joomla 3.10 Alpha 1 : https://github.com/joomla/joomla-cms.../3.10.0-alpha1

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    JoomlaDays, 2 et 3 Octobre. Plus d'infos sur https://www.joomladay.fr

    Commentaire


    • #3
      Petite remarque sur la version 3.10 Alpha 1 : dans la doc. citée plus haut, il est question du "pre-update checker".

      Pour le voir, il faut passer par la configuration du composant "Mise à jour Joomla", choisir le Canal de mise à jour à "Test" et choisir "Alpha" dans Stabilité minimale.

      Cela vous donnera un onglet supplémentaire dans "Mise à jour Joomla" : pre-update check".

      Après un 1er test, j'ai plusieurs modules/extensions/plugins qui sont listés dans la partie "Update Information Unavailable" et, après analyse, c'est un gros menteur...

      En fait, ce module vérifie si, dans les fichiers de mises à jour des extensions, la ligne targetplateform contient une valeur 3.*, les autres valeurs étant considérées comme "info. non disponible".

      Or, j'ai certains plugins/modules qui nécessitent Joomla 3.9 minimum (quand je joue avec les actions logs) ou Joomla 3.7 (quand il s'agit des custom fields). Donc, je n'ai pas trouvé la syntaxe pour dire 3.9 minimum ou 3.7 minimun et suivants. La syntaxe version="3.[789] donne des extensions non prévues Joomla 3.10..

      Si quelqu'un a la bonne syntaxe, merci de me dire.

      Pascal
      If anything can go wrong, it will...
      If I can help, I will ..https://conseilgouz.com

      JoomlaDays, 2 et 3 Octobre. Plus d'infos sur https://www.joomladay.fr

      Commentaire


      • #4
        En ce qui me concerne, pour LazyDbBackup par exemple, j'ai séparé en 3 parties "update" les infos de maj,en vue d'une éventuelle modification spécifique à J! 4, et pour test sur la 3.10 :
        <targetplatform name="joomla" version="3.[6789]|10"/>
        <targetplatform name="joomla" version="3.10"/>
        <targetplatform name="joomla" version="4"/>

        Pour la 3.10, j'ai signalé une version 3.8.8 (en fait non disponible), qui n'est donc proposée que pour cette version 3.10
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Merci pour cette syntaxe, j'avais raté l'utilisation du pipe |.

          Pascal
          If anything can go wrong, it will...
          If I can help, I will ..https://conseilgouz.com

          JoomlaDays, 2 et 3 Octobre. Plus d'infos sur https://www.joomladay.fr

          Commentaire


          • #6
            Pour ma part, je suis en test de BreezingForms sur J!4 Beta 2 jusque là et Beta 3 depuis aujourd'hui.

            J'ai remarqué que dans Beta 2, un lien vers un article précis n'était pas possible, la sélection de l'article restait inerte. C'est réparé avec Beta 3…

            Je commence à me faire à la nouvelle interface d'admin et trouver mes petits… Au début, c'était galère de savoir quoi se trouve où…
            Je patauge encore un peu puor certaines fonctions mais c'est déjà bien mieux.
            Cordialement.
            __
            Eddy !!!
            Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

            Commentaire


            • #7
              Bonjour,

              Un problème de langue avec la version 4 : si j'en crois les noms des fichiers de langue installés et ce que m'avait dit Jean-Marie, le code de langue disparaît des noms de fichiers, on n'a par exemple plus à nommer "fr-FR.plg_system.nom-du-plugin.ini" mais seulement "plg_system.nom-du-plugin.ini".
              Je viens donc de supprimer ce code des noms de fichiers de LazyDbBackup et J! 4 ne sait pas interpréter les traductions des chaînes en anglais ! Le débogage de langue signale que les fichiers ne sont pas chargés.
              J'installe le pack de langue 3.9.20 (dommage qu'on ne puisse pas tester le pack de la 4 ), je passe en français, j'ouvre la page de LazyDbBackup, elle est en français et le fichier est bien interprété...
              Et je ne comprends pas pourquoi : en anglais, fichier non chargé, mais aucune erreur signalée !
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #8
                Bonjour,

                C'est vraiment très curieux : testé avec le français et l'allemand, les fichiers de langue de LazyDbBackup sont bien chargés.
                En anglais, c'est le remplacement de "_QQ_" par un guillemet double qui empêche leur chargement ! Si je remplace par une double apostrophe, tout va bien !!!
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X