Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

MAJ 3.7.1 vers 3.8.2 = erreur 500 plus aucun accès

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • MAJ 3.7.1 vers 3.8.2 = erreur 500 plus aucun accès

    Bonjour,

    Ben voilà, ça devait finir par arriver.
    Je suis toujours hyper stressée par les opérations de mise à jour, et pourtant jusqu'ici il ne m'était rien arrivé.
    Mais là, ce coup là, c'est la totale ;(
    Plus aucun accès à l'admin, et site inaccessible........

    Côté front page, tout ce qui s'affiche c'est :
    Error displaying the error page

    Côté admin : j'ai un écran bleu, vide, aucun message, rien nada
    La seule chose que je puisse lire c'est le titre de l'onglet dans mon navigateur, qui dit : "Error 500 : Application instantiation error"

    Help !
    J'ai bien essayé de lire un post qui parle d'un problème d'erreur 500 suite à cette même màj, mais c'est bien trop technique pour moi...

    Désespérément,
    Flo
    --

    en attendant vos conseils, j'essaie la tactique décrite ici https://forum.joomla.fr/node/1968299
    je renomme administrator/modules/mod_menu en mod_menuold
    ça ne change rien du tout ...

    Quant à la tactique décrite ici, comme elle se réfère à un autre post, pour moi pauvre imbécile c'est incompréhensible :
    https://forum.joomla.fr/node/228050
    quel fichier faut-il modifier ??


    Edit 22h49 : ayant recouvré l'accès à mon back et mon front en retournant sous l'ancienne version, il n'y a plus le feu, je retire le "au secouuurs" de mon titre mais le problème reste entier ! màj impossible...
    Dernière édition par FlodAriege à 12/11/2017, 22h51

  • #2
    Bonsoir,

    Les manip. décrites par LNA fonctionnent dans un ou deux cas de figures, pas dans tous les cas.

    Donc, la question: avez-vous une sauvegarde avant migration ?

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Oui, oui, heureusement...
      Je suis d'ailleurs en train de la restaurer, en croisant les doigts pour que tout se passe bien (j'ai viré tout le contenu du dossier racine pour ne pas qu'il traîne des machins source de problème).
      Ça ne résoudra pas le problème de fond (il faudra bien que j'y passe, à cette màj), mais au moins ça rétablira le site (je l'espère)...
      Je suis assez choquée de voir le nom de messages sur le forum signalant des dysfonctionnements du même genre que le mien suite au passage à la 3.8
      Les solutions indiquées semblent en plus particulièrement techniques, donc inaccessibles à une webmaster amateure comme moi.
      Une chose est sûre, la prochaine fois avant de mettre à jour, je regarderai sur le forum pour savoir si la version est "problématique" ou pas...

      Sauf que...
      imposssible de se connecter à la base de données !!
      Unable to connect to the Database: Could not connect to MySQL.

      database server host name :
      d'après mon panneau 1and1 c'est un truc du genre : db123456789.db.1and1.com
      username : c'est un truc du genre dbo123456789
      password : de peur d'avoir mal enregistré mon MDP, au 1er échec de connexion, je suis allée le changer, ai patiemment attendu la mise à jour sur mon panneau 1and1, puis suis revenue le copier-coller
      database name : c'est un truc du genre db123456789

      et là je deviens folle
      ça ne marche pas
      j'essaie avec localhost à la place de db123456789.db.1and1.com
      sans succès
      j'essaie avec 127.0.0.1
      sans succès


      il me semble me souvenir qu'il y avait un truc spécial sur le nom du serveur, mais je suis infichue de retrouver le post où un contributeur me l'avait soufflé il y a 3 ans...

      edit 22:40
      de guerre lasse, j'ai fini par recréer une toute nouvelle base de données.
      et pour mémoire (la mienne essentiellement), le database server host name c'est bien le truc du genre db123456789.db.1and1.com
      j'ai enfin réussi à restaurer mon site.
      en joomla 3.7.1 évidemment.
      mais après la journée que je viens de passer, je ne suis pas prête de retenter l'aventure du 3.8.x avant qu'on m'explique pourquoi ça a foiré la première fois...
      Le problème reste donc entier (si ce n'est qu'il n'y a plus le feu au lac)
      Dernière édition par FlodAriege à 12/11/2017, 22h49

      Commentaire


      • #4
        Bonsoir,
        j'ai enfin réussi à restaurer mon site.
        en joomla 3.7.1 évidemment.
        mais après la journée que je viens de passer, je ne suis pas prête de retenter l'aventure du 3.8.x avant qu'on m'explique pourquoi ça a foiré la première fois...
        Il s'en est passé des choses depuis la 3.7.1 !!!
        Ceci explique en partie cela
        Sinon, avec un si grand écart, il vaut mieux tester les mises a jour sur un serveur local ou dans un sous domaine comme ça, tu ne risque pas de déstabiliser le site en ligne
        Pour les soucis rencontrés, il aurait fallu un peu plus de détail
        Jday 2018 - 18/19 Mai !!! J'y serai ... et vous ?

        Commentaire


        • #5
          Bonsoir,

          Il y a eu une mise à jour du framework de ton template ?
          Tu peux vérifier auprès de Joomlashine et leur forum.

          Egalement les extensions (plugins, composants, modules).

          Désactive au besoin jchtoptimize, le cache et remplace temporairement le htaccess pour une version standard
          avant de procéder à la mise à jour de joomla.

          Enfin si tu affiche le rapport d'erreurs (configuration/serveur/rapport d'erreur à "developpement", tu évite la page vide
          et les indications te donneront certainement les fichiers qui posent problème.)

          Yann

          JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

          Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

          Commentaire


          • #6
            Bonjour,

            De mémoire Flodariege utilise JSN Epic (version 1) PRO comme moi et effectivement il y a eu au moment du passage en 3.8 un changement de framework Joomlashine obligatoire sinon c'était plantage assuré.

            Donc refaire une sauvegarde impérativement et mettre à jour le framework lié au template, ça ne réglera peut-être pas tout mais sans le faire ce n'est tout simplement pas possible !

            Cordialement
            Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

            Commentaire


            • #7
              Envoyé par daneel Voir le message

              Il y a eu une mise à jour du framework de ton template ?
              Oui, absolument, et je l'ai faite avant de mettre à jour Joomla!
              Sans aucun problème, à tel point qu'après avoir réinstallé ma sauvegarde, j'ai refait la mise à jour du framework et sans aucun souci.

              Envoyé par daneel Voir le message

              Egalement les extensions (plugins, composants, modules).
              J'ai pris l'habitude (peut-être mauvaise ?) au fil du temps, de réaliser les mises à jour dans l'ordre suivant :
              1. les extensions (sauf les NoNumber / Regular Labs, qui demandent plutôt à êtr faite sur un Joomla! bien à jour)
              2. le framework du template (voire le template)
              3. Joomla!
              4. flexicontent
              5. les extensions NoNumber Regular Labs

              Cette fois-ci, j'avais fait les màj suivantes avant Joomla!, dans cet ordre:
              Akeeba Backup
              Chronoforms v5
              JCE Edutopr Core
              JCH Optimize
              JSN Template Framework

              à ce stade il ne me restait plus que joomla, flexicontent et les nonumber, mais la màj Joomla! m'a fait m'arrêter là...
              Je précise que j'ai remis à jour toutes ces extensions sans aucun problème depuis.
              mais je suis restée en J3.7.1. (trop peur !)

              Envoyé par daneel Voir le message
              Désactive au besoin jchtoptimize, le cache et remplace temporairement le htaccess pour une version standard
              avant de procéder à la mise à jour de joomla.

              Enfin si tu affiche le rapport d'erreurs (configuration/serveur/rapport d'erreur à "developpement", tu évite la page vide
              et les indications te donneront certainement les fichiers qui posent problème.)

              Yann
              Merci Yann, je vais essayer de mettre à profit tes conseils, mais sur un sous-domaine de test (si toutefois j'y arrive... j'ai créé une base de données dans l'idée de mener qq tests sur mon site, mais je ne suis pas très au clair sur ce que je dois faire pour que ce sous-domaine reste caché aux yeux de tou-tes sauf moi).
              Quant à mener le test en local, j'avoue que ça fait si longtemps que je n'ai plus fait la manip que ça m'angoisse rien que d'y penser...

              Commentaire


              • #8
                Envoyé par PieceOfCake Voir le message
                Bonjour,

                De mémoire Flodariege utilise JSN Epic (version 1) PRO comme moi et effectivement il y a eu au moment du passage en 3.8 un changement de framework Joomlashine obligatoire sinon c'était plantage assuré.

                Donc refaire une sauvegarde impérativement et mettre à jour le framework lié au template, ça ne réglera peut-être pas tout mais sans le faire ce n'est tout simplement pas possible !

                Cordialement
                Waouh quelle mémoire PieceofCake !!
                C'est (presque) ça !
                JSN Boot Pro.

                Cependant, comme je l'indiquais dans ma réponse précédente, j'ai bel et bien mis à jour mon framework AVANT de tenter la mise à jour Joomla!
                On me l'avait conseillé ici même il y a longtemps, et c'est une consigne qui figure en bonne place dans ma check-list "MAJ".

                Le problème vient donc d'ailleurs...

                Commentaire

                Travaille ...
                X