Identifiant de parent invalide.

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Identifiant de parent invalide.

    Bonsoir,
    J'ai ce message qui s'affiche chaque fois que j'enregistre un article :
    L'enregistrement a échoué avec l'erreur suivante : Identifiant de parent invalide. mais l'article est tout de même finalement enregistré. je souhaiterai supprimer ce message qui est désagréable car le même article est rechargé lorsqu'on fait enregistrer et fermer

    Merci

  • #2
    Re : Identifiant de parent invalide.

    Il faudrait en dire plus : version de joomla, install en local (avec Xampp, Wampp, etc.?) ou chez un hébergeur (lequel ?).
    Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
    Confucius

    Commentaire


    • #3
      Re : Identifiant de parent invalide.

      Salut et merci pour la réponse.

      Le site est développé avec Joomla 1.6 (mis à jour vers 1.7 - mais le problème existe avant la mise à jour) et hébergé chez webhostingpad

      Commentaire


      • #4
        Re : Identifiant de parent invalide.

        Nouvelle installation de Joomla 1.7, à la création d'un nouvel article ou la modification d'un ancien j'ai le même message.

        Site héberger sur serveur Maven hosting + templates Camber (rockettheme)+ JCE 2010 FR

        Commentaire


        • #5
          Re : Identifiant de parent invalide.

          Pouvez-vous vérifier, dans la base de données, dans la table [préfixe]_content, quelle est la valeur de parentid ? Dans mon cas parentid vaut 0 (pour tous les articles)

          Commentaire


          • #6
            Re : Identifiant de parent invalide.

            Solution trouvée:
            1. Il faut aller dans la gestion des catégories, cocher l'ensemble des catégories et cliquer sur le fléche bleue circulaire "reconstruire". Un message apparaît alors indiquant que l'arbre des catégories a été reconstruit.
            2. Puis en commençant par la catégorie parente, puis par les sous catégorie, ouvrir la catégorie (aucune modification nécessaire) et simplement enregistrer et fermer
            3. Faire ça à chaque fois que le problème se présente sur une catégorie.


            En ce qui me concerne le problème à été résolu de cette manière

            Commentaire


            • #7
              Re : Identifiant de parent invalide.

              Slt

              J'ai le meme probleme sous joomla 2.5.6 mais j'aimerais bien savoir d'ou ca peut venir, car j'ai pas envie de me taper toutes les categorie (environs 40) a chaque fois que ca fait ca (en tout cas merci onca pour ta "solution" ).

              Comme mon serveur2Go est sur un disque dur que je trimbale entre 2 ordis, j'ai utilise MoovJla pour modifier les chemins (peut etre que ca venait de ca). Mais ca n'y fait rien.
              Mon site de photos du Pays Basque : nenex-argazkia.net

              Commentaire


              • #8
                Re : Identifiant de parent invalide.

                Envoyé par onca Voir le message
                Solution trouvée:
                1. Il faut aller dans la gestion des catégories, cocher l'ensemble des catégories et cliquer sur le fléche bleue circulaire "reconstruire". Un message apparaît alors indiquant que l'arbre des catégories a été reconstruit.
                2. Puis en commençant par la catégorie parente, puis par les sous catégorie, ouvrir la catégorie (aucune modification nécessaire) et simplement enregistrer et fermer
                3. Faire ça à chaque fois que le problème se présente sur une catégorie.


                En ce qui me concerne le problème à été résolu de cette manière
                Merci : ça marche.

                J'ajoute que si le problème persiste, pour une sous-catégorie, il suffit de faire de même pour la(les) catégorie(s) parent(s) en partant du haut.

                Commentaire


                • #9
                  Re : Identifiant de parent invalide.

                  Envoyé par PACHAT Voir le message
                  Merci : ça marche.

                  J'ajoute que si le problème persiste, pour une sous-catégorie, il suffit de faire de même pour la(les) catégorie(s) parent(s) en partant du haut.
                  Merci.

                  Commentaire


                  • #10
                    Re : Identifiant de parent invalide.

                    Bonjour,
                    Je ne sais pas si ce post est marqué comme étant réglé mais je ne veux pas en ouvrir un autre avec le même sujet vu que j'ai exactement le même problème sur tout mes articles malgré la solution de reconstruire les catégories etc... le problème persiste .
                    J'ai le version 2.5.4
                    Une idée?

                    Commentaire


                    • #11
                      Re : Identifiant de parent invalide.

                      Envoyé par crisca Voir le message
                      Bonjour,
                      Je ne sais pas si ce post est marqué comme étant réglé mais je ne veux pas en ouvrir un autre avec le même sujet vu que j'ai exactement le même problème sur tout mes articles malgré la solution de reconstruire les catégories etc... le problème persiste .
                      J'ai le version 2.5.4
                      Une idée?
                      Bonjour,

                      Dans un premier temps il serait nécessaire de mettre à jour votre Joomla 2.5.4 en 2.5.9 (voir cette documentation pour mettre à jour automatiquement son Joomla).
                      Ensuite, il faudra refaire un test.
                      Dernière édition par XdiZ à 13/03/2013, 10h59
                      Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
                      Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
                      Je ne donne pas suite aux messages privés (MP) non sollicités !

                      Commentaire


                      • #12
                        Re : Identifiant de parent invalide.

                        En ce qui me concerne, c'est sous J!3.0 que le problème a été réglé en suivant la méthode.

                        Commentaire


                        • #13
                          Re : Identifiant de parent invalide.

                          Bonjour

                          Merci beaucoup pour cette explication. Testée sur joomla 2.5.9 et 3.0 et les 2 fonctionnent (comme j'ai pas mal de catégories, je ne reconstruits que les catégories et sous-catégories concernées).

                          Commentaire


                          • #14
                            Joomla 3.9
                            La solution de Onca (message #6) fonctionne
                            Merci

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins

                            Partenaire de l'association

                            Réduire

                            Hébergeur Web PlanetHoster
                            Travaille ...
                            X