Prob avec les liens de menus/sous-menus

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Prob avec les liens de menus/sous-menus

    Bonjour à tous,

    Novice avec Joomla, je me suis formé avec Elephorm et j'ai bien compris l'organisation et le travail d'élaboration.

    J'ai créé mon premier site, avec le template "Identity" de ThemeForest (http://themeforest.net/item/identity...emplate/310326).

    J'ai un gros souci avec le MegaMenu de ce template. Sur mon menu "présentation", j'arrive à placer n'importe quel lien, et ça fonctionne. Le contenu du lien est visible. Par contre, les liens des autres menus ne fonctionnent pas du tout, m'indiquant une erreur du type: internal servor error.

    Je n'arrive pas à comprendre ce qu'il se passe. J'ai lu et relu toute la documentation que j'ai en ma possession.

    Que dois-je faire? Quel est le truc que j'ai "zappé"?

    Je vous donne le lien de mon site en construction: http://www.etoilescompagnie.be


    Merci d'avance pour votre aide.

    Vincent

  • #2
    Re : Prob avec les liens de menus/sous-menus

    Bonsoir,

    Commences par désactiver le SEO dans la configuration, si retour à la normal il faut jouer avec le fichier htaccess.txt, en le modifiant suivant ton hébergeur et en le renommant en .htaccess.

    Commentaire


    • #3
      Re : Prob avec les liens de menus/sous-menus

      Euh, désolé, c'est un peu du charabia pour moi :-s

      Dans la configuration du template? ou de joomla? Excusez-moi d'être à ce point "dans le brouillard".

      Commentaire


      • #4
        Re : Prob avec les liens de menus/sous-menus

        Bonjour,
        Dans la configuration du template? ou de joomla?
        Bah, ça ne fait que deux endroits à regarder

        Configuration de Joomla, premier onglet, pavé SEO en haut à droite, passe ce qui est à" oui" à "non"
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Re : Prob avec les liens de menus/sous-menus

          Je devais vraiment être fatigué hier pour ne pas voir cet onglet, écrit clairement!!! :-)

          Je vous remercie pour cette indication, les menus fonctionnent à merveille. Le fait d'avoir désactivé cet élément, je dois faire autre chose pour pouvoir le ré-activer après ou c'est bon comme ça?

          Quelqu'un peut m'expliquer à quoi sert cet onglet SEO?



          Merci à vous deux pour la solution en tous les cas; je vais pouvoir continuer l'élaboration de mon site.

          Bonne journée,
          Vincent

          Commentaire


          • #6
            Re : Prob avec les liens de menus/sous-menus

            Bonjour,
            le SEO c'est ce qui permet aux url de resembler à tonsite/tarubrique/tonsujet.html au lieu de tonsite/index.php?option=com_content etc.
            Il faudra donc le réactiver un jour, mais à ce moment là active aussi la réécriture "à la volée" avec .htaccess.
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X