migration virtuemart 2.0 pas d'image produit

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] migration virtuemart 2.0 pas d'image produit

    [post issu du forum j1.5 erreur de ma part je suis en 2.5]
    hello
    voila j'ai fini ma migration vers virtuemart 2.0 ..
    le soucis c'est que mes images sont bien dans le dossier images/stories/virtuemart ...
    mais aucun de mes produits n'a d'images referencer dans ces fiches produits ... suis je obliger de toute les remettre à la mains ?
    Merci d'avance
    Société : http://www.com3elles.com
    Bénévole : http://www.flexicontent.org

  • #2
    Re : migration virtuemart 2.0 pas d'image produit

    Bonjour,

    avez vous essayez d'aller voir dans la rubrique media du menu de virtuemart et de vérifier que les images y sont bien publiées ?
    Marcus77
    https://www.materiel-grand-format.fr
    https://www.emaging.fr

    Commentaire


    • #3
      Re : migration virtuemart 2.0 pas d'image produit

      les images y sont mais elles ne sont pas associer au produit
      Société : http://www.com3elles.com
      Bénévole : http://www.flexicontent.org

      Commentaire


      • #4
        Re : migration virtuemart 2.0 pas d'image produit

        Avez-vous résolu le problème ? J'ai le même souci, les images sont bien dans "Medias" et publiées, mais elles n'apparaissent pas dans les fiches produit...

        Commentaire


        • #5
          Re : migration virtuemart 2.0 pas d'image produit

          Bonjour,
          J'ai eu le meme problème.
          En fait, il faut d'abord mettre l'ensemble des photos dans le bon dossier,
          puis faire la migration.
          Si la migration est faite avant, il ne détecte pas les images et ne les prend donc
          pas en compte.

          Commentaire


          • #6
            Re : migration virtuemart 2.0 pas d'image produit

            Même problème …
            - Les images ex shop_image ont bien été placées, avant migration, dans images/stories/virtuemart avec les sous-dossiers category, products, manufacturer et vendor.
            - Après la migration vers VM2, on les retrouve dans boutique/media, mais pas dans Produits/Catégories de produits ou Produits. Aucun affichage en front-end.
            - Dans Commandes & Clients, je retrouve aussi les Groupes clients et les Clients. Au chapitre des fournisseurs : tous présents.
            - Par contre, par ce même menu, les commandes sont absentes.

            Où faut-il chercher l'erreur ?
            Dans le chaos du compliqué, trouver la solution simple qui n'est pas simpliste car elle permet le complexe …
            http://www.markagement.com

            Commentaire


            • #7
              Re : migration virtuemart 2.0 pas d'image produit

              ... j'ai eu pareil .. j'ai remis les image a la mains
              Société : http://www.com3elles.com
              Bénévole : http://www.flexicontent.org

              Commentaire


              • #8
                Re : migration virtuemart 2.0 pas d'image produit

                Pour ma part,
                j'ai d'abord installer un pack joomla 2.5+virtuemart 2 sur un site test.
                Ensuite j'ai mis toutes les photos dans le bon dossier.
                Puis j'ai insérer toutes les bases virtuemart 1 (que l'on pourra supprimer par la suite)
                Ensuite j'ai réalisé les migrations.
                Et cela a fonctionné (toutes les bases réinsérées).
                Toutes les photos produits ont été trouvées.
                (Exception quand meme de 3 photos catégories qui comportaient des accents, donc cela s'explique)
                Par contre, je viens de me rendre compte que lorsqu'un produit comportait plusieurs
                photos, pour l'instant seule la première a été trouvé (je vais y regarder c'est peut être le dossier média).
                Voilà mon expérience si ça peut aider...

                Commentaire


                • #9
                  Re : migration virtuemart 2.0 pas d'image produit

                  Pour l'instant je ne trouve pas la solution pour les autres images produits. La première est bien prise en compte mais pas les autres alors qu'elles apparaissent bien dans la table virtuemart_medias mais il n'y a aucune association dans le fichier virtuemart_product_media...
                  Je n'ai donc qu'une photo par produit.
                  quelqu'un a-t-il trouvé la solution ?

                  Commentaire


                  • #10
                    Re : migration virtuemart 2.0 pas d'image produit

                    En recommençant toute la procédure pour passer d'abord de Joomla1.5 à 2.5 puis de VM1.1 à VM2.0 (avec les exemples qui fonctionnent bien), toutes les photos de mon site se sont retrouvées dans virtuemart/Shop/Media-Files.

                    En activant la case virtuemart/configuration/template/Show categories, ces dernières sont alors bien présentes en front end (absentes dans le cas contraire), mais seuls les articles de jardinage y sont visibles.

                    Y aurait-il dans les paramètres de réglage de VM2 une activation des articles bien cachée ?

                    P.S.: Merci à y.berges de sa solution, mais avec 1000 photos à transférer … En outre, j'aimerais bien y arriver par la méthode classique !
                    Dernière édition par PhMi à 18/10/2012, 16h40
                    Dans le chaos du compliqué, trouver la solution simple qui n'est pas simpliste car elle permet le complexe …
                    http://www.markagement.com

                    Commentaire


                    • #11
                      Re : migration virtuemart 2.0 pas d'image produit

                      Aviez vous plusieurs photos pour un produit ?

                      Commentaire


                      • #12
                        Re : migration virtuemart 2.0 pas d'image produit

                        Chaque produit à une seule photo.

                        Lorsque vous avez plusieurs vues, vous pourriez les fusionner en une seule photo.

                        Bon courage.
                        Dans le chaos du compliqué, trouver la solution simple qui n'est pas simpliste car elle permet le complexe …
                        http://www.markagement.com

                        Commentaire


                        • #13
                          Re : migration virtuemart 2.0 pas d'image produit

                          Patience et longueur de temps …

                          A force de tourner le problème dans tous les sens, j'ai mis mon nez dans phpMyAdmin pour constater que toutes les tables "jos" avaient été dupliquées en "jnew", mais que si jnew_virtuemart_media contenait toutes les images de mon site, jnew_virtuemart_products ou jnew_virtuemart_category n'en présentait aucune et jnew_virtuemart_userinfos ne listait que 10% des utilisateurs de mon site.

                          J'ai alors soupçonné que la migration n'était pas terminée. J'ai donc recommencé à actionner le bouton "Migration" et constaté que le contenu du bandeau bleu présentant, au dessus de lui, des "infos" évoluait. Au bout d'une VINGTAINE de cycles, il s'est stabilisé et les catégories et produits sont apparus en front-end ainsi que les commandes et les utilisateurs dans l'administration …

                          Si y.berges et facilitant pouvaient confirmer que c'est bien la manœuvre à faire, le premier d'entre eux pourrait passer cette question en Résolu …

                          P.S.: J'ai lu que les tables jos pouvaient être éliminées : exact ? Peut-on faire subir le même sort aux tables jnew qui en sont juste la copie ? Merci.
                          Dernière édition par PhMi à 21/10/2012, 23h28
                          Dans le chaos du compliqué, trouver la solution simple qui n'est pas simpliste car elle permet le complexe …
                          http://www.markagement.com

                          Commentaire


                          • #14
                            Re : migration virtuemart 2.0 pas d'image produit

                            Bonjour,
                            C'est bien la manoeuvre a faire.
                            Néanmoins, l'outil de migration ne prend a priori qu'une seule photo produit en compte.
                            Les autres ajoutées ne sont pas associées aux produits mais entre bien dans la table média...
                            J'avais pensé faire une moulinette mysql pour les réassocier mais les id produits ne sont plus les mêmes entre
                            VM1 et VM2...
                            J'ai 400 produits et refaire le boulot me rebute complètement...

                            Commentaire


                            • #15
                              Re : migration virtuemart 2.0 pas d'image produit

                              ... moi j'en avais 90 j'ai refais a la mains ...
                              Société : http://www.com3elles.com
                              Bénévole : http://www.flexicontent.org

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X