EXTEXPLORER : ne fonctionne pas, message d'erreurs

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] EXTEXPLORER : ne fonctionne pas, message d'erreurs

    Bonjour,

    Je suis chez Infomaniak avec Joomla 2.5 à jour ! (Joomlatutos, Kit Joomla). J'ai suivi les conseils de Sarki et installé le composant Joomla Extexplorer.

    Quand je lance le composant depuis l'administration :
    <- Retour à l'administration de Joomla!
    [ATTACH=CONFIG]22924[/ATTACH]
    Mode courant: extplorer [D�connecter].
    Vous pouvez passer en mode ftp.

    Warning: include(/home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/scripts/application.js.php) [function.include]: failed to open stream: No such file or directory in /home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/include/list.php on line 385

    Warning: include() [function.include]: Failed opening '/home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/scripts/application.js.php' for inclusion (include_path='.:/opt/php/lib/php') in /home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/include/list.php on line 385
    puis en cliquant sur «Vous pouvez passer en mode FTP» :

    Notice: Undefined property: JAdministrator::$JComponentTitle in /home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/modules/mod_title/mod_title.php on line 13

    Notice: Undefined variable: authentication_type in /home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/include/login.php on line 57

    <- Retour à l'administration de Joomla!
    [ATTACH=CONFIG]22924[/ATTACH]
    Mode courant: extplorer [D�connecter].
    Vous pouvez passer en mode ftp.

    Warning: include(/home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/scripts/application.js.php) [function.include]: failed to open stream: No such file or directory in /home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/include/list.php on line 385

    Warning: include() [function.include]: Failed opening '/home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/scripts/application.js.php' for inclusion (include_path='.:/opt/php/lib/php') in /home/www/54f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/include/list.php on line 385
    Fichiers joints
    Merci par avance
    Cordialement,
    Dominique

    _(°v°)_ C'est chouette Internet !

  • #2
    Re : EXTEXPLORER : ne fonctionne pas, message d'erreurs

    Bonjour

    Ce sont des warnings et des Notify ==> pas vraiment des erreurs.

    Il faut juste désactiver l'affichage de telles erreurs sur un site de production. Cela se fait en mettant la variable error_reporting à 0. Plein de posts sur ce forum en parle; faites p.ex. une recherche sur "Strict standards" sur le forum et vous obtiendrez plusieurs réponses.
    Christophe (cavo789)
    Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

    Commentaire


    • #3
      Re : EXTEXPLORER : ne fonctionne pas, message d'erreurs

      Bonjour Cavo

      Merci beaucoup ... Et pour aider celui qui a le même problème et qui lira ce post, j'ai trouvé effectivement ceci avec le mot «error_reporting» :

      Re : des lignes d'alerte Strict Standards: en visualisation du site apres maj

      Je n'avais pas lu les bons mails....
      merci beaucoup j'y suis retournée et j'ai trouvé cela qui m'a bien arrangé.... :

      Le mode strict a été introduit en PHP 5.2 mais se révèle redoutable avec PHP 5.3. Il s'agit non pas d'une erreur mais d'un avertissement. Dans le cas présent, il signale qu'une méthode non statique de JModuleHelper est appelée avec la syntaxe statique JModuleHelper::getLayoutPath().
      Pour que Joomla ne te casse plus les pieds avec ça. Modifies à la main ton configuration.php, la ligne:
      Code:
      var $error_reporting = '-1';
      ou quelque soit la valeur courante en:
      Code:
      var $error_reporting = '6135';
      Pour comprendre la valeur 6135, une petite lecture des paramètres error_reporting, avec des et et ou logiques est indispensable.


      et voilà ouf


      MERCI beaucoup
      is@
      Merci par avance
      Cordialement,
      Dominique

      _(°v°)_ C'est chouette Internet !

      Commentaire


      • #4
        Re : EXTEXPLORER : ne fonctionne pas, message d'erreurs

        Bonjour Cavo,

        J'ai fait ce que j'ai mis dans le post précédent et cela ne fonctionne pas !!?? Puis j'ai désinstallé eXtexplorer puis je l'ai ré-installé. Je me suis aperçu que j'avais un message d'erreur qui est le suivant :

        Warning: unlink(/home/www/56f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/scripts.tar.gz) [function.unlink]: Permission denied in /home/www/56f90f371402b3ee8b448a0f742fabd3/web/site/administrator/components/com_extplorer/install.extplorer.php on line 30
        C'est toujours cet «error_reporting» ? Pourtant dans configuration.php, il est à 'none'.

        Sic ! que faire ?
        Merci par avance
        Cordialement,
        Dominique

        _(°v°)_ C'est chouette Internet !

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X