Mes articles ne passent pas en mode edition.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Mes articles ne passent pas en mode edition.

    Bonsoir,

    J'utilise un template artisteer, voici son url http://www.artisteer.com/?template_i...tegory_id=1306

    Malgré l'utilisation d'un lien de menu de type "connexion", je n'arrive pas à faire passer mes articles en mode édition.

    J'ai pourtant bien définit les droits au niveau des articles.

    J'ai l'impression que cela viens de l'utilisation de ce template ?
    Dernière édition par rmanf30 à 18/09/2011, 23h08

  • #2
    Re : Mes articles ne passent pas en mode edition.

    Uu petit UP (ce sera le seul)

    Je galère vraiment, je ne trouve pas.

    Commentaire


    • #3
      Re : Mes articles ne passent pas en mode edition.

      Bonjour,
      Malgré l'utilisation d'un lien de menu de type "connexion", je n'arrive pas à faire passer mes articles en mode édition.
      J'ai pourtant bien définit les droits au niveau des articles.
      La connexion se passe bien ?
      Et si tu utilises un profil super-admin (histoire d'évacuer le facteur "droits" ?
      Et si tu utilises un autre template ?
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        Re : Mes articles ne passent pas en mode edition.

        Bonjour,

        - Oui la connexion se passe bien, je la constate dans l'interface d'administration qui m'indique : 1 (site)
        - Si j'utilise un autre template ca fonctionne.
        - Je teste avec mon profil "Super Utilisateur" que j'ai positionné dans les groupes "Administrateur" et "Super utilisateur"

        Commentaire


        • #5
          Re : Mes articles ne passent pas en mode edition.

          Re,
          tout simplement (!) ce p.... de template Artis.... embarque une surcharge du com_content qui n'inclut pas le bouton d'édition.
          Compare par exemple templates/tontemplate/html/com_content/article/default.php avec com_content/views/article/tmpl/default.php
          Il manque - entre autres :
          Code:
          <?php if ($canEdit) : ?>
          	<li class="edit-icon">
          		<?php echo JHtml::_('icon.edit', $this->item, $params); ?>
          	</li>
          <?php endif; ?>
          Schtroumpfe toi le Schtroumpf t'aidera.
          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

          Commentaire


          • #6
            Re : Mes articles ne passent pas en mode edition.

            Bon ...

            Je comprends que mon problème viens du template, je comprends également que récupérer des templates de démonstration n'est pas forcément une bonne idée.

            Je constate que j'ai beaucoup de mal à comprendre ce que tu m'explique.

            Je vais donc arrêter de me prendre la tête avec p... de template, prendre un bon tuto et essayer d'en créer un (même très moche) pour comprendre comment tout cela fonctionne.

            Je te remercie de t'être intéressé à mon problème.

            Commentaire


            • #7
              Re : Mes articles ne passent pas en mode edition.

              Re,
              Je constate que j'ai beaucoup de mal à comprendre ce que tu m'explique.
              Dans les templates, il y a la possibilité de faire des surcharge des composants, c'est à dire redéfinir le script php qui gère l'affichage des composants ou des modules.
              En mettant dans un template un fichier /html/com_content/article/default.php, il sera utilisé par Joomla à la place de components/com_content/views/article/tmpl/default.php, et on va donc personnaliser l'affichage, en l'occurence des articles.
              Dans notre cas, les surcharges sont codées avec les pieds, et n'on conservé que l'essentiel de l'affichage de base, ignorant pas mal de paramètres et pour ce qui t'intéresse le bouton de modification.
              Plutôt que repartir de 0, il existe pas mal de templates gratuits de qualité (par exemple joomlaos.de) dont tu pourrais partir...
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Re : Mes articles ne passent pas en mode edition.

                Super top ton explication

                Dans un premier temps pour voir si javais bien compris, j'ai renomé mon répertoire en html/com_content/xxxarticle/default.php et génial c’était bien ça.

                Bien que le résultat soit satisfaisant, pour le fun je vais essayer de comparer les codes et intégrer ce qui manque.

                Merci beaucoup, ce soir j'ai vraiment l'impression d'avoir avancé dans la compréhension des mécanismes de Joomla!

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X