Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

    Bonjour,

    Je viens de passer de Joomla 2.5.8 vers 3.3.6 après avoir vérifié la compatibilité de toutes mes extensions.

    Tout est OK à part un détail important.

    En format "Blog" l'affichage des articles ( en vedette ou pas) se passe bien, mais aucun titre ni le lien "lire la suite" ne s'affichent.
    Dans un article simple, le titre s'affiche bien.
    J'ai essayé de publier un nouvel article dans ce blog, même chose.

    J'ai vérifié et re-vérifié tous les paramètres d'affichages d'articles, liens de menus, etc, tout est OK mais les titres et le lien ne s'affichent toujours pas. Ca marchait impec sous Joomla 2.5.8

    Quelqu'un peut-il m'aider, mille merci ?

    Joomla 3.3.6 / PHP 5_4 / Firefox / editeur JCE

  • #2
    Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

    Bonjour,

    Un lien vers le site pourrait aider à tracer le problème.
    Sans lien, quid de deviner le pourquoi du comment de la chose
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

      Waouh ! Plus vite que l'éclair..
      Merci beaucoup
      le site www.ambitionfrance.org
      Page d'acceuil paramétrée en blog des articles en vedette
      (mentions légales en bas, article unique)

      Encore merci pour ton aide
      Piluche

      Commentaire


      • #4
        Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

        Vu sur le site la collection de
        Strict Standards: Only variables should be assigned by reference
        il faudrait commencer par passer le rapport d'erreurs de Joomla! à "Aucun" ou configurer PHP en mode exploitation au lieu de mode développement.

        Ce qui résoudrait vraisemblablement le genre de problèmes rencontrés. On dirait bien qu'il y a une mixture d'extensions Joomla! 3.x et de modules 2.5 pas complètement compatibles.
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

          Merci de ton aide
          Je ne suis pas un "cador" en php
          1/ J'ai passé le rapport d'erreur à aucun : pas de changement
          2/ Comment passer PHP en mode "exploitation" ?
          Mon .htacces est ainsi :
          SetEnv REGISTER_GLOBALS 0
          SetEnv ZEND_OPTIMIZER 1
          SetEnv MAGIC_QUOTES 0
          SetEnv PHP_VER 5_4

          2/Je vais vérifier mes modules et voir si certains ne sont pas compatibles. J'ai du en laisser trainer...
          La bonne méthode est-elle de les déactiver un à un et de vérifier si cela résout le problème ?

          On va y arriver...
          Bon dimanche

          Cordialement,

          Piluche

          Commentaire


          • #6
            Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

            Oui, désactives les extensions une à une et vérifies à chaque fois. Quand tu tomberas sur celles qui posent problème, il suffira de les mettre à jour.
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

              Ok, je vais faire et te tient au courant
              J'en ai déjà désactivé pas mal ( les douteuses) et ça ne change rien pour l'instant
              A suivre
              Merci encore
              Piluche

              Mon .htacces est-il ok ?
              Comment passer PHP en mode exploitation ?

              Commentaire


              • #8
                Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                Ce code .htaccess ressemble à une vieille configuration OVH. Il me semble que chez OVH maintenant, il faut utiliser un fichier ovhconfig https://www.ovh.com/fr/g1207.configurer-php-web
                Pas de demande de support par MP.
                S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                Commentaire


                • #9
                  Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                  C'est fait. j'ai installé la nouvelle config php d'ovh (merci) mais rien n'y fait.

                  Je viens de balayer toutes les extensions, sans succès.

                  J'ai toujours ce problème d'affichage des titres et du lien "lire la suite" dans mon affichage en blogs, mais pas en article unique.

                  Je pense ré-installer complètement Joomla 3.3.6 dans un sous répertoire du site, le lier à la base de données existante et ré-installer les extensions nécessaires au fonctionnement du site dans leur version compatible.
                  Et rebasculer le tout à la racine du site

                  Est-ce une bonne solution ?

                  [EDIT]Mot de passe et login en clair


                  Je suis vraiment dans la panade

                  Mille merci d'avance

                  Piluche
                  Dernière édition par ghazal à 22/02/2015, 20h04 Raison: Pas de mot de passe / login en clair

                  Commentaire


                  • #10
                    Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                    @piluche
                    message corrigé.
                    Ne donne pas des mots de passe et login sur un forum public.
                    Adresse-les par Message Privé à la personne concernée.
                    Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

                    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                    Commentaire


                    • #11
                      Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                      Merci du conseil ghazal, erreur de "jeunesse" sur ce Forum
                      J'ai désactivé l'utilisateur par sécurité et j'adresserai un message perso à jisse03
                      Maintenant, si tu peux me venir aussi en aide, je ne suis pas un expert et suis dans la panade avec ce problème.
                      Merci d'avance
                      Piluche

                      Commentaire


                      • #12
                        Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                        Il apparait que tu as supprimé les identifiants potentiellement critiques, ce qui est une bonne chose.
                        Envoie-moi de nouveaux par MP.
                        Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

                        Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                        Commentaire


                        • #13
                          Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                          As-tu repassé le template par la moulinette Artisteer, la dernière version ?
                          Je pose la question mais je ne sais même pas si c'est possible, n'ayant jamais utilisé ce bidule.
                          Parce qu'il y a des incohérences dans le code dans templates/ton_template/html/com_content/featured/
                          Et pas grand chose ne fonctionne dans le passage des paramètres (articles et catégories).
                          En gros, le code n'est pas vraiment à jour p/r à joomla 3.3.6
                          Perso, je ne touche pas ce code.

                          NB : nous sommes un certain nombre sur le forum à apprécier modérément les templates faits avec Artisteer, pour ce genre de raison précisément.

                          Je continue à regarder, mais j'ai bien peur que tu doives soit réviser le template, soit en changer.
                          Du taf en perspective.

                          Solution (prothèse?) de secours, mais ultra casse-pieds et provisoire :
                          1- j'ai changé d'éditeur pour mon "user", "TEST" -> codemirror

                          Le titre de l'article d'exemple est : "Face à la violence, l’école française ...", id=1279.

                          2 - tu insères le lien vers l'article avant le readmore sur le texte que tu veux.
                          Pour cela, tu récupères, dans le champ d'adresse de l'admin, l'url de ce lien :
                          index.php?option=com_content&view=article&layout=e dit&id=1279
                          Tu vires :
                          &layout=edit
                          Résultat :
                          index.php?option=com_content&view=article&id=1279
                          PS : si tu vois & à la place de &, c'est normal (traduction classique d'une entité HTML)

                          3 - dans Images et liens, tu fais bien attention à mettre le "Lien A' à "Ouvrir dans la fenêtre parente"

                          4 : PB de cette solution,
                          outre le fait d'être galère - et provisoire -, on ne récupère pas la catégorie dans le breadcrumb.

                          Bon courage.
                          Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

                          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                          Commentaire


                          • #14
                            Re : Titres des articles ne s'affichent plus en format blog - Joomla 3.3.6

                            Merci pour toutes ces précisions et ta gentillesse à passer de ton temps sur mon problème.

                            J'ai utilisé Artisteer car je suis incapable d'écrire du code. Je suis un "vieux" monsieur (66 ans) qui s'est mis à la création de sites pour mes amis avec les CMS, extensions et outils accessibles à tous.
                            A priori, Artisteer dans sa dernière version fournit des Templates adaptés à J3.3.X
                            Je l'ai utilisé pour d'autres sites sous Joomla 3.3.6 et tout va bien.

                            J'ai aussi testé le Template Protostar inclus dans le package Joomla. Même chose.
                            je suppose donc que cela ne vient pas du template utilisé mais d'un autre problème.

                            Je veux bien utiliser ta solution (en sauvetage immédiat) mais tu as raison c'est galère et pas ce que je souhaite retrouver.
                            D'autant plus que j'ai plus de 100 articles à modifier...

                            J'ai pensé ré-installer J3.3.6 et toutes les extensions à jour dans un sous répertoire, le faire pointer sur la base existante, et rapatrier le tout à la racine du site.
                            Est-ce une solution envisageable ?
                            Merci de ton avis

                            Amicalement,
                            piluche
                            Dernière édition par piluche à 23/02/2015, 18h09

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins

                            Partenaire de l'association

                            Réduire

                            Hébergeur Web PlanetHoster
                            Travaille ...
                            X