Blocage en Back End pour une restauration avec Akeeba kickstart 7.1.0

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Andéa
    a répondu
    Bon rien ne marche correctement.
    J'ai donc dézippé le fichier en local et je suis allé chercher avec l’explorateur tout ce qui m'intéresse.

    Merci de votre contribution.
    Andéa

    Laisser un commentaire:


  • Andéa
    a répondu
    Merci, à vous deux, pour vos contributions, je vais regarder cela !

    Andéa.

    Laisser un commentaire:


  • dolmenhir
    a répondu
    Salut,

    J'ai déjà rencontré un problème similaire (BO vide) dont la cause venait du template choisi pour le BO incompatible avec la version PHP du serveur.
    Je suis allé le modifier dans la BDD pour utiliser le template ISIS par défaut et c'est rentré dans l'ordre.

    Un plugin peut aussi poser ce genre de problème.

    Une autre astuce plus basique consiste à envoyer par FTP (puisque pas d'accès a BO) l'ensemble des fichier natif de la version Joomla utilisée afin d'écraser un éventuel fichier corrompu par un fichier sain.

    Enfin, il ne faut pas écarter l'idée qu'une extension contrôle peut être l'accès au BO (genre AdminTools ou RSFirewall) auquel cas la désactiver (de préférence en éditant la table Components dans la BDD) pourrait permettre de retrouver l'accès au BO.

    Laisser un commentaire:


  • RobertG
    a répondu
    Bonjour,

    Dans template_styles, de mémoire

    Laisser un commentaire:


  • Andéa
    a répondu
    Bonjour,
    Je veux bien le modifier, mais dans quelle table ?

    Merci.

    Laisser un commentaire:


  • RobertG
    a répondu
    Bonjour,

    Comme souvent dit à propos de Joomla! 4, les templates Joomla! 3 ne sont pas compatibles, sauf les plus récents. Il est d'ailleurs conseillé de définir protostar comme template par défaut avant la migration.
    Modifie dans la base de données le template du site pour Cassiopeia, ce qui empêchera, je pense, rt myriad de sévir côté administration.

    Laisser un commentaire:


  • Andéa
    a répondu
    Çà y est j'ai enfin des erreurs qui s'affichent sur le BO après avoir configuré le configuration.php sur : $debug = '1' et $error_reporting = 'development'

    Voici ce qui apparait à l'affichage :

    Warning: require_once(/xxx/xxx/www/yyy/libraries/joomla/document/html/renderer/head.php): failed to open stream: No such file or directory in /xxx/xxx/www/yyy/templates/rt_myriad/error.php on line 166

    Fatal error: require_once(): Failed opening required '/xxx/xxx/www/yyy/libraries/joomla/document/html/renderer/head.php' (include_path='.:/usr/local/php5.6/lib/php') in /xxx/xxx/www/yyy/templates/rt_myriad/error.php on line 166

    Bon pour faire marcher ses erreurs, au lieu d'une page blanche, j'ai comme vous le voyez passé en PHP v 5.6 temporairement.

    De vous lire, en vous remerciant par avance de votre contribution.

    Andéa

    Laisser un commentaire:


  • Andéa
    a répondu
    Merci à tous pour vos contributions !

    Je vais en fait tout écraser et repartir de zéro
    J'ai sauvegarder mes photos et media, ma base SQL...
    J'ai fais un bilan de mes modules installés, images perso, et données...

    Et après un l'install je ferais par progression FTP sur mes photos, media et tenterait de réincorporer la base de données, en ayant bien sur tout sauvegardé, avant pour revenir en arrière si nécessaire et étape par étape.

    J'informerais sur le thread de mon avancé, pour si quelqu'un, un jour ce pose la même question. Je ne passe donc pas encore en [Réglé].

    Merci à vous et à bientôt.

    Andéa.

    Laisser un commentaire:


  • RobertG
    a répondu
    Le plus souvent, ce qui bloque est un plugin, mais quand on a activé le débogage et mis le rapport d'erreur au maximum, on a une liste de fichiers ayant provoqué l'erreur, ce qui n'est pas le cas, si j'ai bien compris.
    Ce que je tenterais c'est d'écraser le site avec une version équivalente de Joomla!, au cas où ce seraient des fichiers qui auraient été mal sauvegardés ou restaurés.

    Laisser un commentaire:


  • Andéa
    a répondu
    Merci pour votre retour !

    Malheureusement il n'y a pas de dossier de template rocket dans ce répertoire :

    Bien à vous !

    Laisser un commentaire:


  • laurentdubois
    a répondu
    Bonjour, peut être une piste que je n'ai jamais essayé :
    Tu dois avoir un répertoire de ton template rocket... en admin /administrator/templates
    Essaie de vider le dossier du template rocket... et copie dedans tous les fichiers et dossiers du template hathor.

    Laisser un commentaire:


  • Andéa
    a répondu
    Merci,

    Tout fonctionne en FO n'est pas en BO.
    J'ai dit en #10 que :

    Le Front End répond bien présent partout..
    L'accès au Back Office à bien lieu et le champ (de la base de donnée) lastvisiteDate de la table xxx_users confirme un changement et une bonne date (2021-10-11 22:01).

    On peut donc en déduire que la base de données et bien sollicitée autant en FO qu'en BO.
    J'ai oublié de préciser que le BO ne fonctionne toujours pas, malgré une page d'accueil invitant à s'identifier, puis passage à une page blanche avec comme code source :

    Code HTML:
    <div class="row-fluid"> <div class="span3"> <div class="cpanel-links">
    et rien de plus

    Le site à été installé par un fichier de RocketTheme de mémoire.
    Je ne sais plus mais peut être que Rockettheme proposé un package Joomla + template et extension.
    J'ai peut être du l'installer par ce qu'ils disent : Joomle 3.x RocketLancher

    Si c'est cela c'est "cuit" ?
    Pourtant le Front Office fonctionne

    Merci

    Andéa

    Laisser un commentaire:


  • RobertG
    a répondu
    Il est probable que ce site a été initialement créé à partir d'un quickstart. A mon avis, tu peux le supprimer.

    Mais tu ne viens pas de dire (message #10) que tout fonctionnait après cette nouvelle restauration ? Pourquoi voudrais-tu repartir de zéro ? Je ne te suis vraiment plus.

    Laisser un commentaire:


  • Andéa
    a répondu
    Arrête-toi là !
    Va dans la configuration depuis l'administration, et contente-toi d'enregistrer et quitter. Ces localhost ne pouvant pas se définir dans la gestion de la configuration, il n'y a pas lieu de toucher au fichier lui-même.
    Ok, mais je comprend pas... dans la pratique.
    Je passe par FilleZilla sur configuration.php sur le serveur ?

    Va dans la configuration depuis l'administration,
    Je n'ai pas accès à l'adminsitration puisque ça bloque après l’identification dans le BO pour me donner que :
    Code HTML:
    <div class="row-fluid"> <div class="span3"> <div class="cpanel-links">
    Code de la fameuse page vierge...

    Laisser un commentaire:


  • Andéa
    a répondu
    Je viens de trouver un truc louche :
    Il existe un fichier install.script.php à la racine (root) provenant de chez RocketTheme

    Si on l'ouvre il indique :
    • The RocketLauncher package should not be installed into an existing Joomla instance. It is a stand-alone Joomla installation.
    soit en Fr :
    • Le package RocketLauncher ne doit pas être installé dans une instance Joomla existante. Il s'agit d'une installation Joomla autonome.
    Est ce la clé du problème ?
    Et comment faire ?
    Ce n'est pas mon cas puisque je ne fais que de la restauration.

    Pour avoir le cœur net, je suis allé décompresser l'archive site-anciennomdedomaine-2018xxxx-xxx.zip
    Ce fichier existe bien depuis 2015.
    Donc cela n'a pas l'air de venir de là .

    Rien à faire encore.
    Je me demande, à ce stade, si je ne devrais pas réinstaller Joomla avec le template de RocketTheme et ses extensions........
    Repartir de zéro quoi.

    Quand pensez-vous ?

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X