Template Protostar

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Template Protostar

    Bonjour,
    Je créé un site avec le Template Protostar.
    Concernant la version mobile, depuis peu le menu déroulant qui contenait les menus Top ne fonctionne plus.
    Que faire pour le rendre fonctionnel ?
    Merci pour votre aide.
    Voici l'adresse de mon site en cours de construction :
    argonautes.club
    Arzi7777

  • #2
    Salut,
    lerreur javascript est celle ci:
    TypeError: $(...).find(...).tooltip is not a function ligne 48 du fichier template.js
    Cette erreur est souvent due à un austre script javascript qui utilise aussi le $, donc conflit entre les deux.
    Sur mon protostar, je n ais pas cette erreur.

    dans le fichier template.js, modifier la ligne 48 comme ceci :
    Code:
    $(container || document).find('*[rel=tooltip]').tooltip();
    a remplacer par
    Code:
    jQuery(container || document).find('*[rel=tooltip]').tooltip();
    Ensuite ctrl +F5 et retester.
    regardes dans l'onglet console de l'inspecteur d'éléments si tu as une autre erreur si cela ne fonctionnes pas.
    Mon site en cours de construction avec de nouvelles catégories de documents...
    https://informaticien51.fr

    Commentaire


    • #3
      Bonjour
      Merci pour ta réponse.
      J'ai ouvert le fichier template.js. Il y avait bien l'erreur que tu indiques. J'ai corrigé via le ftp car avec le nouvel interface Admin, je ne sais pas pourquoi je n'ai plus accès aux fichiers du template notamment le css. Il y a bien un menu "gestion des fichiers " mais il ne répond pas.
      Cela ne marche toujours pas sur mon mobile.
      Avec mes remerciements.

      Commentaire


      • #4
        Re-bonjour
        Finalement, le problème est réglé. Après avoir corrigé le fichier template.js via le ftp, j'ai fini par faire la toute dernière mise à jour de Joomla 3.19. Leurs mises en garde sur les extensions me rebutaient. Dans l'admin j'ai pu enfin avoir accès aux fichiers du Template. Après cette mise à jour, j'ai constaté qu'il y a bien un $ et je crois d'autres éléments ont été modifiés. En tout cas ça marche.
        Merci pour votre aide.

        Commentaire


        • #5
          Bonjour
          Comme dit précédemment, la version mobile fonctionne bien, qu'il y ait jQuery ou $. J'ai testé les deux.
          J'ai un autre problème qui me fait penser qu'il y a peut-être un conflit avec un autre Javascript comme tu le dis dans ton message.
          Dans l'éditeur de texte, TinyMCE ou JCE, la fonction Article, lien sur un article du site ne marche pas. Les articles s'affichent bien mais quand je pointe sur l'un d'eux c'est inopérant. J'ai testé avec les deux versions du template.js, c'est pareil.
          J'ai un contournement pour créer le lien mais cela ne me satisfait pas.
          Bonne journée.

          Commentaire


          • #6
            tu as quelle erreur dans la console de l'inspecteur d'éléments?
            Mon site en cours de construction avec de nouvelles catégories de documents...
            https://informaticien51.fr

            Commentaire


            • #7
              Je ne suis pas familiarisée avec cet outil. Je me suis mise dans la page de contenu d'un article, puis j'ai actionné l'inspecteur d'éléments.

              Dans l'onglet "Console", j'ai trouvé :
              JQMIGRATE: Migrate is installed, version 1.4.1

              jquery-migrate.min.js?b2c26696f2b8f19133b5b809bb500d4b:2

              Je ne sais pas si c'est ce qu'il fallait faire.

              Commentaire


              • #8
                En pointant sur l'onglet "Article" de l'éditeur et avec bouton droit puis inspecter voila ce que j'ai trouvé :
                Mixed Content: The page at 'https://argonautes.club/administrator/index.php?option=com_content&view=article&layout=e dit&id=85' was loaded over HTTPS, but requested an insecure image 'http://www.clubdesargonautes.org/5images/interrogation.gif'. This content should also be served over HTTPS.
                Je transfert le contenu du site clubdesargonautes.org sur Joomla (argonautes.club) Il se peut qu'il reste un lien sur une image de ce site.

                Commentaire


                • #9
                  Il se peut qu'il reste un lien sur une image de ce site.
                  C'est exactement ca.
                  le contenu mixte est du à ceci. ta page est chargée via un lien en https(sécurisé), et le lien vers ton image est en http (non sécurisé). Donc il faut recréer le lien vers l'image depuis ton site en https.
                  Ceci mettras a jour celui ci et cette erreur disparaitra.
                  Mon site en cours de construction avec de nouvelles catégories de documents...
                  https://informaticien51.fr

                  Commentaire


                  • #10
                    Le lien pointes ou quand tu utilise le bouton article?
                    regardes en bas a gauche de la fenetre, il est souvent indiqué ici.
                    Mon site en cours de construction avec de nouvelles catégories de documents...
                    https://informaticien51.fr

                    Commentaire


                    • #11
                      Bonjour
                      J'ai retiré l'image qui avait effectivement un lien avec un site non sécurisé.
                      Puis j'ai refait inspecter sur l'onglet "Article" ou "Image" et j'ai trouvé ces deux mêmes messages d'erreur dans les deux cas :

                      JQMIGRATE: Migrate is installed, version 1.4.1

                      /administrator/index.php?option=com_content&view=articles&layout= modal&tmpl=component&4ad723bf3ca1c4529dd9e94801e22 0c6=1&editor=jform_articletext:147
                      Uncaught TypeError: window.parent.jSelectArticle is not a function

                      ---------------------------------------------------

                      jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1

                      2/administrator/index.php?option=com_content&view=articles&layout= modal&tmpl=component&4ad723bf3ca1c4529dd9e94801e22 0c6=1&editor=jform_articletext:179 Uncaught TypeError: window.parent.jSelectArticle is not a function

                      Merci pour votre aide.

                      Commentaire


                      • #12
                        LA je seches...je vais aller poser la question aux dev et regarder sur le forum anglais si il y a qqchose a ce propos.

                        Pour le premier message, ce n'est pas une erreur.
                        Mon site en cours de construction avec de nouvelles catégories de documents...
                        https://informaticien51.fr

                        Commentaire


                        • #13
                          Ah j'ai oublié de répondre où pointait le lien quand je survole le bouton article. Voilà :

                          https://argonautes.club/administrato...rm_articletext

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins

                          Partenaire de l'association

                          Réduire

                          Hébergeur Web PlanetHoster
                          Travaille ...
                          X