site multilingue J4

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] site multilingue J4

    Bonjour à tous,
    Depuis quelques jours, j'ai un problème avec un site que je tente de passer en multilingue mais... (forcément) il y à un problème!
    Donc,
    • j'ai bien activé les plugins de langage
    • J'ai activé le module de changement de langue
    • j'ai créé mes pages anglais et Français et...
    La liste déroulante du module de changement de langage est vide
    J'ai "pallié" au problème en créant 2 liens "index.php/en" et "index.php/fr" étant donné que c'est un site onepage, ca fonctionne mais uniquement hors ligne... en ligne, les liens crées une erreur 404

    Donc, pour résumé, je ne comprends pas pourquoi la liste des langue du module reste vide ni pourquoi la modification de la langue ne fonctionne qu'en étant connecté en admin...
    Et, pour finir, je dois le livrer mardi... génial...
    Alors si vous avez des pistes; des idées...

    Précisions:
    • Joomla 4
    • Shaper_helixultimate
    Dernière édition par Darkhan à 03/08/2022, 21h57 Raison: joomla 4

  • #2
    Bonjour,

    As-tu déjà suivi cette marche à suivre ?

    https://www.joomshaper.com/documenta...tilingual-site

    Commentaire


    • #3
      Bonjour,

      As-tu activé le module de vérification multilingue côté administration pour vérifier si ta configuration est correcte ?
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

      Commentaire


      • #4
        Bonjour à tous!
        Alors, oui, j'ai sur les conseils de RobertG activé le module de vérification...
        voilà le résultat :
        Cliquez sur l'image pour l'afficher en taille normale

Nom : verif.jpg 
Affichages : 19 
Taille : 147,8 Ko 
ID : 2041836


        Cela dit, lorsque je me suis connecté au site ce matin (en admin puisqu'hors ligne), j'ai eu l'alerte suivante :
        L'identifiant de sécurité ne correspondait pas. La demande a été interrompue pour empêcher toute violation de sécurité. Veuillez réessayer.
        Est-ce que çà a un lien avec mon problème ?
        Donc, les problèmes du jour sont :
        • Comment palier aux erreurs détectées par le module de vérification
        • Quel est le sens de ce message
        Merci encore à tous de votre aide
        Dernière édition par Darkhan à 05/08/2022, 13h59

        Commentaire


        • #5
          Bonjour,

          C message d'alerte est quelque chose qui m'énerve depuis longtemps. Il suffit de recommencer l'identification ou de penser à rafraîchir la page avant de tenter l'identification.

          Comme tu le vois sur ce que tu as affiché, les pages d'accueil des deux langues ne sont pas définies, ce qui explique les incidents que tu rencontres. Prends le temps de visionner le contenu du lien que t'a donné Helloo et de comparer avec ce que tu as fait.
          Manifestement, tu n'as pas déclaré ces pages d'accueil des langues, peut-être tout simplement parce que tu n'as pas créé deux menus distincts, en plus de celui pour toutes les langues.

          J'oubliais : si tu débutes sur un site neuf, tu peux utiliser l'installation des exemples multilingues ; si c'est un site déjà rempli, tu peux en créer un autre pour tests, et y installer ces exemples, ce qui te montrera l'organisation de base du multilingue.
          Dernière édition par RobertG à 05/08/2022, 14h47
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

          Commentaire


          • #6
            Envoyé par RobertG Voir le message
            Bonjour,

            C message d'alerte est quelque chose qui m'énerve depuis longtemps. Il suffit de recommencer l'identification ou de penser à rafraîchir la page avant de tenter l'identification.

            Comme tu le vois sur ce que tu as affiché, les pages d'accueil des deux langues ne sont pas définies, ce qui explique les incidents que tu rencontres. Prends le temps de visionner le contenu du lien que t'a donné Helloo et de comparer avec ce que tu as fait.
            Manifestement, tu n'as pas déclaré ces pages d'accueil des langues, peut-être tout simplement parce que tu n'as pas créé deux menus distincts, en plus de celui pour toutes les langues.
            Déjà, merci pour ta réponse.
            alors, j'ai utilisé MultilingueCk pour le menu parce que dans Helix Ultimate, le menu est affecté dans le template et pas dans les positions (ou j'ai loupé un épisode, ce qui est possible)
            Mais peut-être que je me trompe... mais je n'ai pas trouver la solution pour définir le menu en fonction de la langue dans ce template

            Commentaire


            • #7
              Lorsqu'un style de template embarque un menu, il faut le dupliquer : un par défaut pour toutes les langues, un style pour chaque langue, ce qui permet de définir le menu correspondant
              Donc déjà, au niveau des menus, tu dois avoir cette distinction au nveau des types de menus pour pouvoir avoir ce choix.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #8
                Alors, je voulais vous dire merci à Helloo et à RobertG, j'ai suivi vos conseils et j'ai trouvé les solutions pour régler le problème.
                En effet, après avoir doublé le template en version FR et GB et en ayant affecté un menu par template j'ai eu une grande avancée mais...
                Mais je n'avais que le drapeau GB qui apparaissait...
                je n'avais pas saisi que le menu FR ne devait pas être le menu principal... et un fois ca compris, j'ai affecté la langue FR et la... miracle!
                Done tout est rentré dans l'ordre et je vais pouvoir partir en weekend paisiblement, alors, merci encore !

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X