Joomladay francophone 2018 à Paris 18 et 19 mai

Discussion au sujet de la version 3.6.3 stable

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Discussion au sujet de la version 3.6.3 stable

    Discussion au sujet de la version 3.6.3 stable.


    MàJ du 19/10 : Retrouvez les solutions aux problèmes d'édition des modules en administration et d'authentification à deux facteurs : https://www.joomla.fr/versions-3-x/i...s-joomla-3-6-3
    Dernière édition par opware2000 à 19/10/2016, 14h56
    cours de SVT - infos scientifiques : www.nicolas-ogier.fr
    pas de demandes d'aide par mp, elles seront systématiquement refusées !

  • #2
    Re : Discussion au sujet de la version 3.6.3 stable

    Bonjour,

    Nous avons déjà commenté largement le problème de cache provoquant un blocage sur l'accès aux modules en administration : http://forum.joomla.fr/showthread.ph...A8me-maj-3-6-3

    Pascal
    JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Re : Discussion au sujet de la version 3.6.3 stable

      Autre problème sur 3.6.3: authentification 2 étapes provoque une erreur : Must match character set.

      Pour passer, désactiver le plugin par phpmyadmin ou renommer JROOT/plugins/twofactorauth

      https://docs.joomla.org/J3.x:Unable_...ed_after_3.6.3

      Pascal
      JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

      If anything can go wrong, it will...
      If I can help, I will ..https://conseilgouz.com

      Commentaire


      • #4
        Re : Discussion au sujet de la version 3.6.3 stable

        Un point que j'avais noté récemment avec la 3.6.2 et que je retrouve à l'instant avec la 3.6.3 : j'ouvre la page des substitutions de langue, par défaut est sélectionné "French (fr-FR) - Site" comme filtre ; je clique sur "Nouveau" et dans la page de création, ce n'est plus "French", mais "English". Il me faut annuler puis cliquer de nouveau sur "Nouveau" pour que ce soit bien "French" qui soit pris en compte.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Re : Discussion au sujet de la version 3.6.3 stable

          Suite à mise à jour 3.6.3 erreur sur plusieurs documents ???
          Erreur
          exception 'RuntimeException' with message 'Error decoding JSON data: Syntax error' in /home/il1z9fgj/public_html/libraries/vendor/joomla/registry/src/Format/Json.php:72 Stack trace: #0 /home/il1z9fgj/public_html/libraries/vendor/joomla/registry/src/Registry.php(366): Joomla\Registry\Format\Json->stringToObject('{"robots":"","a...', Array) #1 /home/il1z9fgj/public_html/components/com_content/models/article.php(180): Joomla\Registry\Registry->loadString('{"robots":"","a...') #2 /home/il1z9fgj/public_html/libraries/legacy/view/legacy.php(408): ContentModelArticle->getItem() #3 /home/il1z9fgj/public_html/components/com_content/views/article/view.html.php(42): JViewLegacy->get('Item') #4 /home/il1z9fgj/public_html/libraries/legacy/controller/legacy.php(664): ContentViewArticle->display() #5 /home/il1z9fgj/public_html/components/com_content/controller.php(113): JControllerLegacy->display(false, Array) #6 /home/il1z9fgj/public_html/libraries/legacy/controller/legacy.php(702): ContentController->display() #7 /home/il1z9fgj/public_html/components/com_content/content.php(38): JControllerLegacy->execute(NULL) #8 /home/il1z9fgj/public_html/libraries/cms/component/helper.php(405): require_once('/home/il1z9fgj/...') #9 /home/il1z9fgj/public_html/libraries/cms/component/helper.php(380): JComponentHelper::executeComponent('/home/il1z9fgj/...') #10 /home/il1z9fgj/public_html/libraries/cms/application/site.php(191): JComponentHelper::renderComponent('com_content') #11 /home/il1z9fgj/public_html/libraries/cms/application/site.php(230): JApplicationSite->dispatch() #12 /home/il1z9fgj/public_html/libraries/cms/application/cms.php(261): JApplicationSite->doExecute() #13 /home/il1z9fgj/public_html/index.php(49): JApplicationCms->execute() #14 {main}

          Commentaire


          • #6
            Re : Discussion au sujet de la version 3.6.3 stable

            Bonjour,

            Il y a une discussion en cours et des tests sur github https://github.com/joomla/joomla-cms/issues/12460 et https://github.com/joomla/joomla-cms/pull/12463.

            Donc, c'est en cours d'analyse, à suivre....

            Pascal
            JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

            If anything can go wrong, it will...
            If I can help, I will ..https://conseilgouz.com

            Commentaire


            • #7
              Re : Discussion au sujet de la version 3.6.3 stable

              Pour le problème JSON,

              Pour l'instant, il y aurait une modification à faire dans libraries/cms/installer/installer.php en ligne 1550 où il faut remplacer return; par return '{}';

              Cela retourne un json vide au lieu de rien.

              Attention: les tests sont en cours, donc à manipuler avec des pincettes.

              Pascal
              JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

              If anything can go wrong, it will...
              If I can help, I will ..https://conseilgouz.com

              Commentaire


              • #8
                Re : Discussion au sujet de la version 3.6.3 stable

                Bonjour à tous

                Pour le cas où, cette information serait utile, le message d'erreur (sur mon site) provient de lien dirigeant vers un article. (entre autre il y a dans l'article qu'une seule image pour présentation).
                Quand je veux modifier cette article : message d'erreur Error decoding JSON data: Syntax error . J'ai dépublié l'article pour en faire un autre avec la même image et j'ai fais la même redirection de mon lien vers ce nouvel article : TOUT fonctionne !

                Je ne pense pas que cela résolve l'erreur JSON mais pour le cas où !!!
                Bien à vous
                Charlyjoom

                Commentaire


                • #9
                  Re : Discussion au sujet de la version 3.6.3 stable

                  Désolé d'avoir été aussi rapide, mais le message d'erreur est également avec des article comportant que du texte

                  Commentaire


                  • #10
                    Re : Discussion au sujet de la version 3.6.3 stable

                    Envoyé par charlyjoom Voir le message
                    Désolé d'avoir été aussi rapide, mais le message d'erreur est également avec des article comportant que du texte
                    Vide bien TOUS tes caches : navigateur, joomla ... et surtout celui du serveur !!! qui peut etre TRES persistant
                    JoomlaDay ... moi j'y serai .. et vous ???
                    Avec Ghazal et Lomart nous guiderons les Grands Débutants au https://www.joomladay.fr/ le 19 mai à Paris
                    C'est le moment ou jamais de venir acquérir ou consolider les bases de ce CMS formidable primé à maintes reprises
                    ... et tout ça dans le partage, la convivialité et la bonne humeur !

                    Commentaire


                    • #11
                      Re : Discussion au sujet de la version 3.6.3 stable

                      Bonjour
                      Je suis entrain de traduire les articles de la faq concernant ce problème.
                      Si vous en utilisez une, purgez également les fichiers de votre CDN qui eux aussi sont très persistants ! (normal me diriez-vous ils sont fait pour !)
                      cours de SVT - infos scientifiques : www.nicolas-ogier.fr
                      pas de demandes d'aide par mp, elles seront systématiquement refusées !

                      Commentaire


                      • #12
                        Re : Discussion au sujet de la version 3.6.3 stable

                        [ manu93fr
                        Tout est OK de ce coté là, c'est fait ! Mais plus j'avance dans mon site, plus je constate le message d'erreur de JSON.
                        Bonjour boulôt.
                        Merci pour ta réponse.
                        Charlyjoom
                        Dernière édition par charlyjoom à 19/10/2016, 15h00

                        Commentaire


                        • #13
                          Re : Discussion au sujet de la version 3.6.3 stable

                          Au niveau JSON, avez-vous essayé la modification suggérée dans le post #7 ?

                          Pascal
                          JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

                          If anything can go wrong, it will...
                          If I can help, I will ..https://conseilgouz.com

                          Commentaire


                          • #14
                            Re : Discussion au sujet de la version 3.6.3 stable

                            Pour info pour tous : Solution au problème d'édition des modules en administration et d'authentification à deux facteurs

                            https://www.joomla.fr/versions-3-x/i...s-joomla-3-6-3
                            cours de SVT - infos scientifiques : www.nicolas-ogier.fr
                            pas de demandes d'aide par mp, elles seront systématiquement refusées !

                            Commentaire


                            • #15
                              Re : Discussion au sujet de la version 3.6.3 stable

                              pmleconte post 7
                              Et bien j'attendais une vrai solution.
                              opware2000
                              je regardes la réponse d'OPWARE

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X