Page Blanche Administration

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Page Blanche Administration

    Bonjour,

    Je suis administrateur d'un site basé sur Joomla. Il est dans sa deuxième version, et la dernière mise à jour date de Aoüt dernier, avec aucun problème depuis. Mais depuis 2 jours je n'arrive plus à accéder à la page administration du site, en effet celle-ci est toute blanche.

    - Dans un 1er temps, j'ai regardé le code source via firefox, et il y a bien tout le code source de la page qui apparait mais en HTML il n'y a rien qui apparait. J'ai également essayer sous Chrome et Internet Explorer en obtenant le même résultat.

    - Dans un deuxième temps, après lecture de votre forum, j'ai activé les erreurs via le fichier configuration.php de la racine du site, mais aucun message d'erreur n'apparait sur la page concerné.

    Du coup, je n'ai aucun accès à ma page d'administration malgré un code qui apparait lorsque je demande "code source" à mon navigateur web.

    Si quelqu'un d'entre vous aurait une solution, je vous en serais très reconnaissant.

    Amicalement,

  • #2
    Re : Page Blanche Administration

    Bienvenue !

    Il est curieux que tu puisses voir le code-source, alors que la page reste blanche : instruction de non affichage (display:none; ) dans la feuille de style ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Re : Page Blanche Administration

      En regardant bien j'ai effectivement une balise <style type="text/css">html { display:none }</style> qui s'est introduit sur cette page... Plus qu'à rechercher comment la supprimer je pense !

      Avez-vous une hypothèse concernant le fichier d'emplacement de cette balise ? Car elle ne se trouve pas dans un css ..
      Dernière édition par fvilleret à 23/12/2013, 21h19

      Commentaire


      • #4
        Re : Page Blanche Administration

        On a ce code dans une page normale d'identification d'accès à l'administration, ça n’explique donc pas l'absence d'affichage.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Re : Page Blanche Administration

          Si vous voulez une idée du problème en question : http://www.ted21.fr/administrator/index.php

          Merci d'avance pour ceux qui auraient une idée ..
          Dernière édition par fvilleret à 23/12/2013, 22h16

          Commentaire


          • #6
            Re : Page Blanche Administration

            En comparant le code-source de cette page et celui d'une version 3.2 neuve, les seules choses qui apparaissent sont des différences sur les "hasTooltip" et la présence de code pour afficher les icônes "identifiant perdu" et "mot de passe oublié" que je n'ai pas sur une version neuve, mais cela n'explique en rien l'absence d'affichage !
            Y a-t-il eu installation d'extensions de sécurité sur ce site ?
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Re : Page Blanche Administration

              Je suis entrain de vérifier auprès des administrateur secondaire mais normalement non, aucune extension n'a été installée ces derniers jours. Enfin, en regardant sur le serveur ftp, à la racine du site, j'ai différentes pages de type twitter, vimeo, facebook qui sont apparus ces derniers jours. Vous pensez que je peux les supprimer directement ou pas ?

              Ou pensez-vous qu'un backup FTP serait plus valable ?
              Dernière édition par fvilleret à 24/12/2013, 10h04

              Commentaire


              • #8
                Re : Page Blanche Administration

                Il n'a à mon avis aucune raison "Joomla!" pour que ce type de pages soient présentes sur le serveur : voir si un administrateur a bricolé pour les y ajouter.
                Bien qu'on ait le code source de cette page d'administration, il faudrait essayer de voir si on peut faire apparaître un message d'erreur en modifiant dans le fichier de configuration "$error_reporting" à "development"
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Re : Page Blanche Administration

                  Je viens de faire la manipulation : il n'y a aucun message d'erreur qui apparaisse sur la page d'administration .. Quelques erreurs de templates apparaissent sur la page d'accueil du site qui apparait normalement.

                  Commentaire


                  • #10
                    Re : Page Blanche Administration

                    Bonjour,

                    En suivant l'URL, le code HTML est bien présent, mais une petite analyse avec l'inspecteur d'éléments de Chromium (ou de chrome ou Opera) ou avec Firebug raconte
                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/jui/css/chosen.css

                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/system/js/mootools-core.js

                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/system/js/core.js

                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/jui/js/jquery.min.js

                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/jui/js/jquery-noconflict.js

                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/jui/js/bootstrap.min.js

                    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.ted21.fr/media/jui/js/chosen.jquery.min.js
                    Soit ces média ont été supprimés, soit le serveur a un très gros problème.
                    Pas de demande de support par MP.
                    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                    Commentaire


                    • #11
                      Re : Page Blanche Administration

                      Bien vu !
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                      Commentaire


                      • #12
                        Re : Page Blanche Administration

                        Pour palier aux différents problèmes, j'ai décidé de faire un back-up FTP du serveur il y a 2 semaines. La page d'administration fonctionne correctement, j'ai mis à jour la version de Joomla que j'avais.

                        Mais un problème est apparu (eh oui) : sur le site, je n'arrive pas à l’authentifié avec mes login car un message d'erreur "Identifiant ou mot de passe incorrect. Essayez de nouveau." apparait à chaque tentative de connection alors que ces login fonctionnent et me permettent d'accéder à la partie administration du site .. Du coup je n'arrive pas à me loguer sur la partie public du site, mais aucun soucis pour accéder à la partir privée ..

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X