Joomladay francophone 2018 à Paris 18 et 19 mai

YOOtheme template: font qui ne se charge pas en front-end

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • YOOtheme template: font qui ne se charge pas en front-end

    Bonjour,
    j’ai un souci de chargement de font que je n’arrive pas à régler avec un template de chez YOOtheme, j’y ai passé pas mal de temps et je ne trouve pas la faille.
    Je tiens à préciser que j’ai déjà écrit sur leurs forums pour avoir de l’aide et si vous avez un peu l’habitude de cet éditeur de template vous devriez connaitre la réputation de leur support. ZERO. C’est scandaleux quand on pense qu’on débourse 100 euros par an pour avoir un support inexistant.
    À titre d’information, je leur avais déjà adressé un email fin de l’année passé en leur disant que si le support n’allait pas changer je n’aurai plus renouvellé mon abonnement. J’ai eu droit à une réponse d’une ligne et demie par la charmante Olivia qui me signalait que mon email allait être transmis au Team. Merci et au revoir.
    Cette année c’est fini, après 5 ans de fidélité ils ne m’auront plus, plus aucun cents ne sortira de ma poche pour cet éditeur de template… bref, ça c’était pour le coup de gueule… à bon entendeur.

    Retour à mon problème que j’ai énoncé en début de message: je n’arrive pas à charger en front-end une nouvelle font pour mon template (template sous Warp 6), pourtant j’ai déjà effectué l’opération l’année passée pour le site en question quand j’ai intégré une font via Font Squirrel.
    La procédure qui est reportée ici a été appliquée à nouveau pas par pas pour la nouvelle font, mais je n'ai aucun résultat positif en front-end.
    Étrangement aucune font (même celles par défaut du template) qui se trouve dans le dossier fonts de mon template n’est chargée, FireBug arrive à l’identifier, mais elle ne se charge pas…
    Quelqu’un qui est familier avec les templates YOOtheme pourrait m’aiguiller?

    Merci

  • #2
    Re : YOOtheme template: font qui ne se charge pas en front-end

    C'est énervant quand ca marche pas.
    Je travaille avec Warp 7, pas évident que ce la s'applique. On va essayer.

    As-tu ce fichier ?
    /templates/yoo_template/layouts/theme.config.php
    Si oui :
    vers la ligne 110
    tu trouveras :
    $this['asset']->addFile('css', 'css:theme.css');
    etc ...
    Tu ajoutes par exemple :
    $this['asset']->addFile('css', 'css:theme.css');

    $this['asset']->addFile('css', 'css:mafont.css');
    Ensuite dans le fichier mafont.css, toujours au début de ce fichier :
    @font-face {
    font-family: 'mafont';
    src: url("mafont/mafont.eot?xqxft6");
    src: url("mafont/mafont.eot?#iefixxqxft6") format("embedded-opentype"), url("mafont/mafont.woff?xqxft6") format("woff"), url("mafont/mafont.ttf?xqxft6") format("truetype"), url("mafont/mafont.svg?xqxft6#mafont") format("svg");
    font-weight: normal;
    font-style: normal; }
    Tu auras créé un dossier "mafont" dans le dossier "css' et placé ta font dans ce dossier.

    Si ce fichier theme.config.php n'existe pas (dans warp 6),
    essaie alors simplement ceci, après avoir suivi les instructions de yoo_theme et créé une ligne :
    // load css
    $this['asset']->addFile('css', 'css:my.css');
    dans le fichier template.config.php

    Ensuite dans le fichier my.css;
    pareil, utilise la méthode classique d'inclusion de font dans une css comme cité plus haut.
    Au pire, tu peux toujours sortir les fichiers de la font de son dossier et les remonter dans le répertoire "css", en modifiant la css en conséquence.

    PS : les bestioles vont bien ?
    Une journée entière pour se former à la gestion d'un site et parler de son futur site avec des experts Joomla!
    Ghazal, Lomart, Manu93fr et pleins d'autres vous attendent le 19 mai pour la journée Grands Débutants au https://www.joomladay.fr de Paris

    Commentaire


    • #3
      Re : YOOtheme template: font qui ne se charge pas en front-end

      Ciao Ghazal… on va commencer à t’appeler Ghazal rescue
      Pas de fichier theme.config.php dans Warp 6… ce que j’ai peut-être oublié de spécifier c’est que j’ai aussi créé un style pour mon template, mais je suppose qu’au final cela ne change pas grand-chose (ou bien si?), j’ai cette arborescence-ci:

      Pour mon css:
      - templates/yoo_solar/styles/cdv/css/mon_fichier.css
      Pour la configuration du template:
      - templates/yoo_solar/styles/mon_style/layouts/template.config.php

      De toute façon l’alternative que tu as proposée, c’est-à-dire d'ajouter un appel au fichier css qui dans ce cas est celui généré par Font Squirrel dans mon fichier template.config.php a réglé le problème:

      $this['asset']->addFile('css', 'css:mafont_squirrel.css');
      … sans oublier bien évidemment de sortir tous les fichiers de la font et de les placer dans le dossier css de mon style.

      Encore une fois tu me donnes un joli coup de pouce et encore une fois je t’en remercie

      Bonne soirée

      P.S … pour les bestioles on fait ce qu’on peut, une peu de douceur dans un monde de brutes.
      Ce week-end on commence à alimenter la petite boutique
      Allez pour la route, le sauvetage de Luna (vimeo.com/110474972), rien à voir avec notre association, mais c'est quand même un sauvetage et c'est tellement beau, difficile de ne pas verser une larme
      Dernière édition par porcini à 05/12/2014, 21h53

      Commentaire

      Annonce

      Réduire
      1 sur 2 < >

      C'est [Réglé] et on n'en parle plus ?

      A quoi ça sert ?
      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
      Comment ajouter la mention [Réglé] à votre discussion ?
      1 - Aller sur votre discussion et éditer votre premier message :


      2 - Cliquer sur la liste déroulante Préfixe.

      3 - Choisir le préfixe [Réglé].


      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

      2 sur 2 < >

      Assistance au forum - Outil de publication d'infos de votre site

      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

      UTILISER À VOS PROPRES RISQUES :
      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

      Problèmes connus :
      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

      Installation :

      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

      Archive zip : https://github.com/AFUJ/FPA/zipball/master

      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
      et remplacer www. votresite .com par votre nom de domaine


      Exemples:
      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
      Télécharger le script fpa-fr.php dans: /public_html/
      Pour executer le script: http://www..com/fpa-fr.php

      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
      Télécharger le script fpa-fr.php dans: /public_html/cms/
      Pour executer le script: http://www..com/cms/fpa-fr.php

      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
      Voir plus
      Voir moins
      Travaille ...
      X