Joomla 2.5.0 est sortie !

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #31
    Re : Joomla 2.5.0 est sortie !

    ok enfin en attendant mon webmaster a essayer de faire une migration en 1.6 et 1.7 et pleins de choses de ne passe pas donc je prendrais aucun risque de quitter pour le moment la 1.5.25 tant que les patchs de sécurité seront fournis par le ou les devellopeurs qui s occupais de la version 1.5 jusqu'a ce jour ou je suis encore sur la 1.5.25 pour le moment je bougerais pas de cette version sans savoir exactement ce qui passera entre la 1.5.25 et la 1.5... ou 1.7 jusqua la 2.5 sortie hier.

    Commentaire


    • #32
      Re : Joomla 2.5.0 est sortie !

      C'est normal.
      C'est en faisant du Joomla que l'on devient Joomlasteur

      Commentaire


      • #33
        Re : Joomla 2.5.0 est sortie !

        Bonjour,
        c'est pour quand la mise à jour qui permet de renommer le répertoire administrateur? Par exemple, lors de processus d'installation, il aura une étape pour choisir le nom de ce répertoire.
        merci à tous

        Commentaire


        • #34
          Re : Joomla 2.5.0 est sortie !

          Bonjour merci de votre réponse

          Envoyé par opware2000 Voir le message
          au contraire c'est même pour réduire les failles de sécurité.
          Oui en principe c'est pour réduire les failles de sécurité sur les anciennes fonctionnalités mais en parallèles les nouvelles seront des proies aux attaques.

          Envoyé par opware2000 Voir le message
          l'avantage d'un cycle court de mise à jour ? permettre d'être plus en adéquation avec les demandes des utilisateurs il me semble (n'étant pas développeur, je m'avance peut être)
          je vous invites à lire les article http://www.joomla.fr/les-news-joomla...ions-de-joomla et http://www.joomla.fr/les-news-joomla...omla-15-16-17-
          Merci pour les liens.

          J'ai vu le calendrier qui est prévu, cela fait peur, on ne dit pas sur quel changement de versions il n'y aura pas de compatibilité: entre 2.5 et 3, 3 et 3.1 ou 3 et 3.5 ou 3 et 4.?

          Pourquoi le système de module ne peut pas répondre aux nouvelles demandes?
          Pourquoi Joomla est-il si monolithique?
          Le nouveau système de base de données SQL ne me servira dans aucun de mes sites déjà installés, pour éviter des problèmes de sécurité faut-il que j'installe la version 2.5?

          Je rêve que l'équipe de joomla envisage le développement d'un noyaux avec le minimum vital et que les nouvelles fonctionnalités se rajoutent à ce noyau solide qui est maintenu!
          Dernière édition par jean érévé à 26/01/2012, 11h13 Raison: orthographe

          Commentaire


          • #35
            Re : Joomla 2.5.0 est sortie !

            Avec un peu plus d informations vous auriez connaissance du fait que joomla 2.5 marque un tournant avec les mises à jour automatique de la version de joomla et des composants donc a l'avenir il sera beaucoup plus simple d'aller vers les nouvelles version les passerelle seront faites ce qui n 'était pas le cas avant

            Commentaire


            • #36
              Re : Joomla 2.5.0 est sortie !

              Bonjour,
              Bonjour,
              c'est pour quand la mise à jour qui permet de renommer le répertoire administrateur? Par exemple, lors de processus d'installation, il aura une étape pour choisir le nom de ce répertoire.
              merci à tous
              Pour cela, tu peux utiliser un composant comme Admin Exile par exemple.
              Le JoomlaDay 2019 c'est le 8 et 9 mars #jd19fr (plus d'infos)

              Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous

              Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

              Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

              Commentaire


              • #37
                Re : Joomla 2.5.0 est sortie !

                Bonjour, merci pour le
                Envoyé par julien Voir le message
                Avec un peu plus d informations ....
                J'avais lu qu'il y aura un système de mise à jour, j' espère du reste qu'il ne sera pas automatique mais à la demande de l'administrateur!
                (J'aime bien lancer un logiciel pour l'utiliser pas pour attendre qu'il ait finit sa mise à jour.)
                La mise à jour automatisé de windows XP ne mène pas vers Seven Je pense que ce sera pareil pour Joomla.
                L'automatisme de mise à jour empêchera-t-il vraiment les problèmes de compatibilité?
                Vous avez des informations où ils parlent de cela?

                Commentaire


                • #38
                  Re : Joomla 2.5.0 est sortie !

                  Je relance la pollémique,sur cette nouvelle version 2.5! c est à celui qui à une version 1.5.25 comment pourra t il passer de cette version à la 2.5 sachant que d avance il perdra son template son forum avec tous c est membres inscrits sur son site sachant que certains modules ne seront pas compatibles depuis les derniéres versions précédentes 1.6,1.7 jusqu'a la 2.5. ds l attente d une réponse ou solution apporter merci.

                  Commentaire


                  • #39
                    Re : Joomla 2.5.0 est sortie !

                    Lorsque je fais une mise à jour via ftp, l'accès au compte utilisateur me donne un message d'erreur (vu sur trois sites différents)

                    Table 'db385181409.h7p52_user_notes' doesn't exist SQL=SELECT n.user_id, COUNT(n.id) As note_count FROM h7p52_user_notes AS n WHERE n.user_id IN (42,43) AND n.state >= 0 GROUP BY n.user_id
                    Sur ce point j'ai réglé le problème en exportant une table sur un site qui l'a vers un site qui ne l'a pas, cela fonctionne...

                    Par contre :
                    Sur un site ou j'ai fait la mise à jour via les extensions, j'ai ce message d'erreur :

                    Installation de fichiers : Fonction DB échouée avec le numéro d'erreur 2006
                    MySQL server has gone away SQL=INSERT INTO `jos_extensions` (`name`,`type`,`element`,`folder`,`enabled`,`prote cted`,`access`,`client_id`,`params`,`system_data`, `manifest_cache`) VALUES ('files_joomla','file','joomla','','1','0','0','0' ,'','','{\"legacy\":false,\"name\":\"files_joomla\ ",\"type\":\"file\",\"creationDate\":\"January 2012\",\"author\":\"Joomla! Project\",\"copyright\":\"(C) 2005 - 2012 Open Source Matters. All rights reserved\",\"authorEmail\":\"admin@joomla.org\",\" authorUrl\":\"www.joomla.org\",\"version\":\"2.5.0 \",\"description\":\"FILES_JOOMLA_XML_DESCRIPTION\ ",\"group\":\"\"}')
                    SQL =
                    INSERT INTO `#__extensions` (`name`,`type`,`element`,`folder`,`enabled`,`prote cted`,`access`,`client_id`,`params`,`system_data`, `manifest_cache`) VALUES ('files_joomla','file','joomla','','1','0','0','0' ,'','','{\"legacy\":false,\"name\":\"files_joomla\ ",\"type\":\"file\",\"creationDate\":\"January 2012\",\"author\":\"Joomla! Project\",\"copyright\":\"(C) 2005 - 2012 Open Source Matters. All rights reserved\",\"authorEmail\":\"admin@joomla.org\",\" authorUrl\":\"www.joomla.org\",\"version\":\"2.5.0 \",\"description\":\"FILES_JOOMLA_XML_DESCRIPTION\ ",\"group\":\"\"}')
                    Erreur de chargement du composant : com_media, 1
                    Erreur de chargement du module MySQL server has gone away SQL=SELECT m.id, m.title, m.module, m.position, m.content, m.showtitle, m.params, mm.menuid FROM jos_modules AS m LEFT JOIN jos_modules_menu AS mm ON mm.moduleid = m.id LEFT JOIN jos_extensions AS e ON e.element = m.module AND e.client_id = m.client_id WHERE m.published = 1 AND e.enabled = 1 AND (m.publish_up = '0000-00-00 00:00:00' OR m.publish_up <= '2012-01-26 10:53:07') AND (m.publish_down = '0000-00-00 00:00:00' OR m.publish_down >= '2012-01-26 10:53:07') AND m.access IN (1,1,2,3) AND m.client_id = 1 AND (mm.menuid = 0 OR mm.menuid <= 0) ORDER BY m.position, m.ordering
                    Je ne comprend pas la signification du message...
                    S'il y a une bonne âme pour m'aiguiller... merci...
                    Dernière édition par act-imm à 26/01/2012, 15h19

                    Commentaire


                    • #40
                      Re : Joomla 2.5.0 est sortie !

                      Envoyé par Sergio Voir le message

                      pas de plugin Captcha trouvé...

                      je pense qu'il doit y avoir un problème
                      je le vois bien avec FileZilla dans le dossier plugins
                      mais pas dans la liste en backend.
                      Bonjour,
                      Suite à la migration, j'avais bien comme toi le dossier captcha dans les plugins mais, le plugin n'apparaissait pas dans la liste.
                      Tu compresses le dossier captcha avec 7z par exemple et tu appliques la procédure d'installation pour ce zip.
                      Tu n'as plus qu'à l'activer et régler les paramètres dans l'application qui l'utilise (contact par exemple).

                      Alvaro
                      Jardiner, c'est respirer!

                      Commentaire


                      • #41
                        Re : Joomla 2.5.0 est sortie !

                        Envoyé par Oscarounet Voir le message
                        Je relance la pollémique,sur cette nouvelle version 2.5! c est à celui qui à une version 1.5.25 comment pourra t il passer de cette version à la 2.5 sachant que d avance il perdra son template son forum avec tous c est membres inscrits sur son site sachant que certains modules ne seront pas compatibles depuis les derniéres versions précédentes 1.6,1.7 jusqu'a la 2.5. ds l attente d une réponse ou solution apporter merci.
                        Tu poses 3x la même demande, je t'ai répondu en te demandant plus d'infos mais sans réponses. J'ai migré 63 sites en J1.5 sans aucun problème particuliers, lorsqu'on utilise les bonnes extensions ont limite la casse éventuelle.

                        Pour le template j'estime que c'est le moins grave de l'histoire, à la limite c'est le moment idéal pour changer, un peu comme on refait les tapisseries/peintures dans une maison, de plus les nouveaux templates sont compatibles directement avec les nouvelles technologies sans ajout d'extension.

                        Commentaire


                        • #42
                          Re : Joomla 2.5.0 est sortie !

                          Bonjour zepelin57

                          Comment avez vous présentez à vos 63 clients la facture de migration du site vers la version 2.5 ?
                          Vous pouvez le faire tous les 6 mois sans qu'ils ne se plaignent?

                          Votre allusion à la tapisserie m'a laissé imaginer un instant que c'est peu être les marchands de Tapis/Template qui ont demander à l'équipe joomla de rende les templates incompatibles, Joomla est gratuit mais il y a un marché sur les templates!

                          Comment faites vous pour savoir à l'avance qu'elle extension sera plus compatibles qu'une autre à un changement de version?
                          Avez vous une liste des bonnes extensions?

                          cordialement.

                          Commentaire


                          • #43
                            Re : Joomla 2.5.0 est sortie !

                            Bonjour,
                            Envoyé par jean érévé Voir le message
                            Comment avez vous présentez à vos 63 clients la facture de migration du site vers la version 2.5 ?
                            Tout bon professionnel sait faire comprendre à ses clients qu'un logiciel a besoin de maintenance, et de temps à autre d'une migration de version, afin de la garder en phase avec les technologies.
                            Quasiment tous les clients, si la chose est clairement présentée, reconnaissent bien le fait, tout comme ils reconnaissent le besoin d'entretien de leur voiture, chaudière ou cheminée...
                            Le logiciel et les services web ne sont pas des "exceptions culturelles" à ce besoin de maintenance.
                            Envoyé par jean érévé Voir le message
                            Vous pouvez le faire tous les 6 mois sans qu'ils ne se plaignent?
                            Une version Joomla! LTS ne dure pas 6 mois, mais 18 mois. Pour le développement interne, et être prêt à migrer ses clients, il est normal qu'on utilise (et parfoi sdéploie pour des nouveaux clients) les versions STS intermédiaires (Joomla! 3.0 dans 6 mois par exemple). Mais pour un client LTS, on ne fait la migration qu'avec la LTS suivante.

                            Envoyé par jean érévé Voir le message
                            Votre allusion à la tapisserie m'a laissé imaginer un instant que c'est peu être les marchands de Tapis/Template qui ont demander à l'équipe joomla de rende les templates incompatibles, Joomla est gratuit mais il y a un marché sur les templates!
                            Les changements concernant les templates n'ont rien à voir avec les vendeurs de templates pro, mais bien plus à la généralisation progressive de HTML 5 et CSS 3, ainsi qu'à l'émergence et montée en puissance d'alternatives (tablettes et mobiles) et à la prise en compte de pas mal de demandes utilisateurs (sites de type web 2.0, meilleur support des normes d'accessibilité, etc.)
                            Mais les modifications à apporter aux templates sont mineures (tout au moins avec les templates bien écrits) afin de prendre en compte ces innovations. Il suffit de regarder le nombre de templates, gratuits et commerciaux, disponibles pour Joomla! 1.7 (version STS intermédiaire) et utilisables sous Joomla! 2.5 sans aucun problème.

                            Envoyé par jean érévé Voir le message
                            Comment faites vous pour savoir à l'avance qu'elle extension sera plus compatibles qu'une autre à un changement de version?
                            Simplement en suivant les mises à jour de ces extensions. Exemple parlant, Community Builder a été disponible pour Joomla! 1.6 quelques jours à peine après la sortie officielle de la version Stable 1.6.0, idem au passage 1.7.0... Les développeurs de ces extensions qui restent à jour anticipent les nouvelles versions de Joomla! en commençant leurs adaptations durant la phase beta test des nouvelelles versions, et de ce fait restent à jour.
                            Par contre, d'autres éditeurs ou auteurs restent figés sur une seule version, et ce sont ces extensions là qui posent le plus souvent problème.

                            Si cette réflexion peut faire avancer un peu
                            Pas de demande de support par MP.
                            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                            Commentaire


                            • #44
                              Re : Joomla 2.5.0 est sortie !

                              Envoyé par zepelin57 Voir le message
                              Tu poses 3x la même demande, je t'ai répondu en te demandant plus d'infos mais sans réponses. J'ai migré 63 sites en J1.5 sans aucun problème particuliers, lorsqu'on utilise les bonnes extensions ont limite la casse éventuelle.

                              Pour le template j'estime que c'est le moins grave de l'histoire, à la limite c'est le moment idéal pour changer, un peu comme on refait les tapisseries/peintures dans une maison, de plus les nouveaux templates sont compatibles directement avec les nouvelles technologies sans ajout d'extension.
                              pour le moment jai rien migrer en 1.6 ni 1.7 et encore moins en 2.5 puisque jai pas la possiblité d atteindre cette nouvelle version d autre part concernant mon template qui est pas compatible en 1.6 et 1.7. et 2.5 ça me plait pas du tout sachant que jai payés pour avoir ce template malgré que soit disant certains sont gratuits ...bref personellement je serais peut étre le seul içi à pas vouloir pour le moment acquérir les versions supérieurs puisques la version 1.5 ne propose pas d aller directement sur la 2.5 sans passer par la 1.6 et 1.7. !!!un update complet de migration ça exsite pas chez joomla d'ou justement 2 à 3 versions avant d arriver malgré pour certains à 2.5 ... car la 1.8 na eut le droit de voir le jour malgré quelle était prévu il me semble bref !!
                              Dernière édition par Oscarounet à 26/01/2012, 22h07

                              Commentaire


                              • #45
                                Re : Joomla 2.5.0 est sortie !

                                Tout bon professionnel sait faire comprendre à ses clients qu'un logiciel a besoin de maintenance, et de temps à autre d'une migration de version, afin de la garder en phase avec les technologies.
                                Quasiment tous les clients, si la chose est clairement présentée, reconnaissent bien le fait, tout comme ils reconnaissent le besoin d'entretien de leur voiture, chaudière ou cheminée...
                                Le logiciel et les services web ne sont pas des "exceptions culturelles" à ce besoin de maintenance.
                                C'est tout à fait cela, personnellement je prévois dans mes contrats de maintenance annuels ce genre d'évolution, car je sais très bien depuis le temps que je fais des sites, que les CMS évoluent, donc pas de (grosses) surprises et tout le monde s'y retrouve.

                                puisques la version 1.5 ne propose pas d aller directement sur la 2.5...
                                Bien sûr que si tu passer directement de la 1.5==>2.5, tu n'es pas obligé de faire 1.5=>1.6=>1.7=>2.5, heureusement d'ailleurs !!!

                                Commentaire

                                Annonce

                                Réduire
                                1 sur 2 < >

                                C'est [Réglé] et on n'en parle plus ?

                                A quoi ça sert ?
                                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                                Comment ajouter la mention [Réglé] à votre discussion ?
                                1 - Aller sur votre discussion et éditer votre premier message :


                                2 - Cliquer sur la liste déroulante Préfixe.

                                3 - Choisir le préfixe [Réglé].


                                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                                2 sur 2 < >

                                Assistance au forum - Outil de publication d'infos de votre site

                                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                                UTILISER À VOS PROPRES RISQUES :
                                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                                Problèmes connus :
                                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                                Installation :

                                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                                et remplacer www. votresite .com par votre nom de domaine


                                Exemples:
                                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                                Télécharger le script fpa-fr.php dans: /public_html/
                                Pour executer le script: http://www..com/fpa-fr.php

                                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                                Télécharger le script fpa-fr.php dans: /public_html/cms/
                                Pour executer le script: http://www..com/cms/fpa-fr.php

                                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                                Voir plus
                                Voir moins

                                Partenaire de l'association

                                Réduire

                                Hébergeur Web PlanetHoster
                                Travaille ...
                                X