Traduction pour Joomla! 4

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • sarki
    a répondu
    Ok super, si jamais voici le lien dédié à J4 sur le forum officiel : https://forum.joomla.org/viewforum.php?f=807

    Laisser un commentaire:


  • RobertG
    a répondu
    Ce problème de Localise est réglé en ce qui concerne les champs de filtres, tous les fichiers du dossier "Field" nécessitent que l'initiale qui est en minuscule soit en majuscule. J'en ai parlé dans une autre discussion, et signalé en "issue" sur sa page Github pour que ça puisse servir à d'autres.
    Je n'ai pas encore poussé plus loin, avec la saturation qu'ont engendrée ces recherches.

    Laisser un commentaire:


  • sarki
    a répondu
    Hello, il serait bien que tu poste sur le forum officiel en anglais, DeepL fait de très bonnes traductions aujourd'hui, car je doute qu'ici quelqu'un soit en mesure de faire avancer ce sujet, et JM n'est pas disponible ces temps et je ne sais pas s'il le sera à nouveau malheureusement...

    Laisser un commentaire:


  • RobertG
    a répondu
    Nouveau test en local avec une RC 3 dev !
    Apache/2.4.46 (Win64) PHP/8.0.7 MariaDB 10.4.13 interface apache2handler (Wamp64) : les champs se remplissent bien ! Idem avec une base MariaDB 10.3.29

    Sur le serveur distant, que PHP tourne en CGi ou en FPM, ça ne change pas, ces champs restent vides.
    Installé sur un autre serveur distant Litespeed, PHP 7.4.20 MariaDB 10.2.38, même problème.

    Et toujours impossible d'installer Joomla! 4 RC sur une base MariaDB 10.5

    Laisser un commentaire:


  • RobertG
    a répondu
    Bonjour,

    Je reviens sur "Localise", à la recherche de la cause du non-remplissage de certains champs dans la liste des traductions.
    Ces listes sont remplies, si j'ai bien interprété, depuis le fichier com_localise/layouts/joomla/searchtools/default.php par les trois variables du code ci-dessous :
    Code PHP:
     <?php
    if ($data['view'] instanceof \Joomla\Component\Localise\Administrator\View\Lang uages\HtmlView
    || $data['view'] instanceof \Joomla\Component\Localise\Administrator\View\Tran slations\HtmlView)
    {
    $clientField $data['view']->filterForm->getField('client');
    $tagField $data['view']->filterForm->getField('tag');
    $developField $data['view']->filterForm->getField('develop'); ?>
    Mais sur ces trois variables, seule $tagField->input renvoie la valeur des langues et remplit la liste déroulante, les deux autres "input" restent vides.

    La question est donc de savoir s'il s'agit d'un mauvais paramétrage de ma part ou une autre cause.

    PS : le test ci-dessus a été fait en écrasant la version précédente de Localise par celle d'infograf789 dans le message #49. Je viens de l'installer, sans aucune modification de paramétrage, sur un site très récent en local (PHP 7.4.9 ou 8.0.7, base MySQL) et là, les champs sont bien remplis. Je désinstalle donc sur l'autre site et je réinstalle cette version : même problème en 7.4.20 et 8.0.7. La seule différence est que sur ce site, la base est en MariaDb : 10.3.29-MariaDB-1:10.3.29+maria~stretch-log
    Sur le site local : MySQL 5.7.31

    Dans une précédente discussion, nous avons été deux à ne pas pouvoir installer Joomla! 4 RC sur une base MariaDB en version récente : https://forum.joomla.fr/forum/joomla...-bdd-joomla-rc
    Dernière édition par RobertG à 23/06/2021, 09h16

    Laisser un commentaire:


  • RobertG
    a répondu
    Envoyé par sarki Voir le message
    @RobertG,
    Je ne comprends pas de quoi tu parles, du composant com_localise ?
    En effet, Mihàli

    Laisser un commentaire:


  • sarki
    a répondu
    @RobertG,
    Je ne comprends pas de quoi tu parles, du composant com_localise ?

    Laisser un commentaire:


  • RobertG
    a répondu
    Bonjour,

    Je viens d'étudier le code généré pour l'affichage de la page des traductions : les deux "datalist" sont vides
    Code:
    echo $clientField->input;
    n'affiche rien (layouts/joomla/serachtools/default.php)

    Je complète : même vide pour "selection client" dans la page des langues
    Dernière édition par RobertG à 10/06/2021, 11h26

    Laisser un commentaire:


  • RobertG
    a répondu
    Merci JM !

    Je viens d'installer ce paquet sur un nouveau site mais les filtres "Site" et "Incomplète" qu'on voit sur ton image sont toujours vides. Pas de listes déroulantes, comme on peut le voir sur l'image que j'ai précédemment montrée.
    J'ai purgé et reformaté dans Localise, sans succès. La console de Firefox est vide.
    Le site étant sous PHP 8.0.6, j'ai installé Localise sur un autre site en PHP 7.4.16 et je n'ai pas mieux.
    Les deux sont en RC2-dev.
    Y a-t-il un paraétrage que j'aurais mal fait. Pour la référence, je lis ceci :
    Source reference
    ADMINISTRATOR client is using the Local installed instance Joomla language files as baseline. You are working on Joomla 4.0.0-rc2-dev version.
    SITE client is using the Local installed instance Joomla language files as baseline. You are working on Joomla 4.0.0-rc2-dev version.

    Please, note that there are clients using a customized version matching your actual Joomla version:

    The client ADMINISTRATOR is using 4.0.0-rc2-dev en-GB baseline reference files as source.
    The client SITE is using 4.0.0-rc2-dev en-GB baseline reference files as source.


    Target reference
    The detected modified values or new keys are fetched from the target language files within the staging branch from the Joomla Github repository.

    The reference files for the ADMINISTRATOR client have never been updated.
    The reference files for the SITE client have never been updated.

    Laisser un commentaire:


  • infograf768
    a répondu
    RobertG
    voici ce que j'ai ici.

    Cliquez sur l'image pour l'afficher en taille normale

Nom : Screen Shot 2021-06-09 at 08.17.58.png 
Affichages : 370 
Taille : 82,6 Ko 
ID : 2028051

    J'essaie de corriger les autres problèmes.
    Installe ce paquet

    com_localise-5.0.0-beta2.zip

    Laisser un commentaire:


  • sarki
    a répondu
    Bon ben infograf768 avait bien raison, avec les modifications apportées au fichier localise.php mais du frontal plus de problème d'affichage avec PHP 8
    Merci JM, qu'est-ce qu'on va faire sans toi...

    Laisser un commentaire:


  • sarki
    a répondu
    En ce qui concerne les actions, ce qui est curieux c'est que chez moi il suffit que je désactive le module "latest actions" pour que l'affichage ne bouge plus, ce qui n'a aucune influence sur l'enregistrement dans la table, seulement sur l'affichage sur le panneau d'administration.
    C'est en effet au niveau de l'affichage que cela pose problème, la désactivation du module permet d'avoir un affichage correct, au même titre que de vider la table des actions puisqu'alors il n'y a plus rien à afficher dans ce module...
    Comme je l'ai dis hier si je change cette valeur abstract class Fr_FRLocalise en abstract class En_GBLocalise dans le localise du frontal cela fonctionne également, il y a donc un problème avec ce fichier.
    Je vais essayer ce soir avec la correction que tu suggères JM et ferai un retour



    Laisser un commentaire:


  • RobertG
    a répondu
    J'ai récupéré il y a quelques temps sur Github une modif du mois d'avril, sans changement pour les filtres, et comme je ne sais pas où ça se génère, je suis bloqué.

    Laisser un commentaire:


  • infograf768
    a répondu

    pas le temps maintenant, mais je n’ai aucun probleme avec les filtres.
    Je n’ai pas mis le repo a jour depuis longtemps

    Laisser un commentaire:


  • RobertG
    a répondu
    Envoyé par infograf768 Voir le message
    com_localise pour J4 en est au stade expérimental.
    j'ai encore des problèmes car J4 change sans arrêt...
    Merci JM ! En fait, sur mon test avec le code que tu proposes sur Github, les champs de filtres sont vides dans la partie traductions sauf celui de choix de la langue, et je n'ai pas trouvé où arriver à trouver pourquoi (j'ai l'habitude de me fier aux messages d'erreur, mais il n'y en a pas).
    Cliquez sur l'image pour l'afficher en taille normale

Nom : localise_210608.jpg 
Affichages : 161 
Taille : 19,8 Ko 
ID : 2028020

    Laisser un commentaire:

Annonce

Réduire
Aucune annonce pour le moment.

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X